UPGRADE 4.0.0beta6 dysfonctionnement xin mo et autres



  • Bonjour à tous,

    J'ai du me recréer un compte car j'ai perdu l'ancien.

    Cela fait un an maintenant que j'utilisais recalbox sur mon PI3.
    J'ai upgrader le système dernièrement et aujourd'hui j'ai eu une nouvelle Maj.

    Les problèmes que je rencontre que je n'avais pas avant sont les suivants :

    • Le mapping de touches (J'utilise un contrôleur XinMo 2J) est devenu laborieux.

    • La configuration des entrées Start et Exit n'existent plus tout comme la double assignation (création de raccourci).

    • Il est Impossibles d'utiliser la Hotkey ("MEME" en l'assignant au bouton select "DEJA" assigné) que ce soit pour J1 comme J2.

    Le mapping des touches diffère entre les différents systèmes et il m'est impossible d'accéder aux menus de ceux-ci que ce soit par les raccourcis et/ou par l'utilisation du clavier (TAB).

    • Le bouton select n'ajoute plus de coin (crédit) mais le bouton R (HK) et le bouton Start ne réagit pas! Sur FBA il devient L (HP).

    • Quitter un jeu se résume donc à appuyer sur "ECHAP", à l'aide du clavier bien sûre.

    Il est 3h du mat et j'y suis depuis l'après midi et j'ai aussi jeté un œil aux cfg, rien n'y fait!

    Si quelqu'un peut m'aider ou a une idée brillante, ça serait super.

    Je suis surtout en train de me tater à downgrader et j'entends par là Formater car j'avais un système qui fonctionnait parfaitement sur l'ancienne version.

    Aahhhh ... le progrès!

    Merci d'avance



  • @AS Personne n'a ce problème apparemment!!


  • Moderator
    Team

    hummmm merci de dire que notre travail est de la merde ....
    ça donne tout de suite envie de lire ton post et de venir donner de son temps pour faire du support technique ...

    enfin ...

    déjà depuis quelle version as tu fait l'upgrade en BETA 6 ? recalbox version ??? -> version beta6 ?

    Car les modifications apportées dans cette dernière release sont réellements minces et n'expliquent en rien tes soucis (comme en atteste le changelog : https://github.com/recalbox/recalbox-os/releases/tag/4.0.0-beta6)



  • @rockaddicted Salut, alors non, loin de moi l'idée de dire que ce que vous faites, c'est de la merde.
    J'ai essayé retropie et j'ai un système Hyperspin et franchement ce que vous faites c'est utile et d'ailleurs je m'étais proposé pour vous aider lors du chantier de refonte de l'interface.

    "C'est la merde" : ma situation, ce n'est pas une erreur de frappe, ni un oubli.
    Désolé pour la confusion.

    J'ai fait l'upgrade via la mise à jour automatique qui as toujours été activée sur mon système.
    J'ai donc upgradé depuis le début 4.0.0-beta2 par palier.

    Et depuis, les contrôles ne fonctionnent plus et le mapping non plus. :(


  • Moderator
    Team

    @AS ,

    Je ne vais malheureusement pas pouvoir t'aider sur tes soucis étant donné que je n'utilise pas de xinmo :s.
    Maintenant tu n'es pas le seul à utiliser cette carte et pour le moment nous n'avons pas eu trop de retour à ce sujet...
    Je laisse les techos voir ce qu'ils ont besoin pour identifier la raison de tout tes soucis.

    Maintenant même si tu dis c'est la merde et non "c'est de la merde", il n’empêche qu'on a des enfants ici donc un peu de retenue flûte ! :p. Mais surtout, dans le titre, il vaut mieux favoriser les pb que le ressenti personnel. Un titre du type "upgrade 4.0beta6 problèmes Xinmo" aurait était plus utile et sans le coté "irritant" que peut avoir le mot "merde" (plus "pute à clics" qu'utile qui plus est). (oui oui j'ai mis le mot pute à clics ;)).

    En revanche, je peux regarder pour te retrouver ton ancien compte si tu le souhaite. Envoi moi par mp le pseudo que tu avais et l'adresse mail rattachée à ce compte. Je verrais ce que je peux faire.


  • Moderator
    Team

    sort nous une archive de support en suivant ce wiki : https://github.com/recalbox/recalbox-os/wiki/Recalbox-support--(FR)



  • @reivaax said in UPGRADE 4.0.0beta6 (C'est la merde):

    oblèmes Xinmo" aurait était plus utile et sans le coté "irritant" que peut avoir le mot "merde" (plus "pute à clics" qu'utile qui plus est). (oui oui j'ai mis le mot pute à clics ;)).

    Ahaha je me suis dis aussi que ça faisait pute à clics!! ahah

    Par contre, concernant mon ancien compte, c'est la même adresse mail.
    Je me suis inscrit le 18/03/2016 à 11:00.



  • @AS said in UPGRADE 4.0.0beta6 (C'est la merde):

    @reivaax said in UPGRADE 4.0.0beta6 (C'est la merde):

    oblèmes Xinmo" aurait était plus utile et sans le coté "irritant" que peut avoir le mot "merde" (plus "pute à clics" qu'utile qui plus est). (oui oui j'ai mis le mot pute à clics ;)).

    Ahaha je me suis dis aussi que ça faisait pute à clics!! ahah

    Par contre, concernant mon ancien compte, c'est la même adresse mail.
    Je me suis inscrit le 18/03/2016 à 11:00.

    Je ferai plus attention la prochaine fois.



  • @rockaddicted ok je vais faire ça.



  • This post is deleted!



  • Moderator
    Team

    hummm rien de choquant ne me saute aux yeux.
    et si tu démarres ta recalbox sans ton clavier de branché, toujours le même soucis ?



  • @rockaddicted Si je la démarre sans le clavier rien n'y fait...du moins c'est du pareil au même.


  • Moderator
    Team

    @AS
    En espérant que tu ais câblé tes joysticks et boutons comme conseillé dans le wiki

    Essaie ceci :

    Si tu as windows, dans une console ssh, via putty :

    1. Monter la partition en écrtiture
      mount -o remount,rw /boot
    2. Editer le fichier cmdline.txt avec notepad++ via winscp (si windows) en ajoutant un espace entre le mot d'avant et ces nouveaux mots.Copie colle cette ligne :
      usbhid.quirks=0x16c0:0x05e1:0x040
      Enregistre la modification et reboot ton raspberry
      En ssh via putty saisir :
      nano /boot/cmdline.txt
      Ajouter la ligne usbhid.quirks=0x16c0:0x05e1:0x040 en ajoutant un espace avec les mots précédents.
      Enregistrer touche cltr+x puis Y pour sortir
      Redémarrer le raspberry
    3. reconfigurer uniquement le joueur 1 dans le menu emulationstation (bouton start) > options manettes > configurer une manette

    bon week end



  • @acris Super je vais tester ça Merci !

    Je n'ai jamais changé le cablage et cela fonctionnait très bien jusqu'à maintenant donc tout devrait être en ordre. Je vais y jeter un oeil.

    Je reviens au nouvelles dès que c'est fait!

    Cheers



  • @acris Voilà ce que j'ai quand j'entre la première commande.

    mount: mounting /dev/mmcblk0p8 on /boot failed: Device or resource busy



  • @acris Effectivement le disque est bloqué en écriture


  • Moderator
    Team

    lis attentivement mes instructions pour effectuer les manipulations @AS



  • @acris RE: J'ai réussi toutes les manips mais la Hotkey ne fonctionne toujours pas.
    Impossible d'Exit in game.

    Et l'assignement des boutons reste :

    Le bouton select n'ajoute plus de coin (crédit) mais le bouton R (HK) et le bouton Start ne réagit pas!.



  • @AS J'ai réussi a sortir d'un jeu en appuyant simultanément sur START SELECT J1 mais sur la GBA. J'ai été voir les conf et les assignements de boutons sont les mêmes que sur les autres émulateurs.

    Quid ?



Want to support us ?

Join us on :

395
Online

28242
Users

14448
Topics

109334
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.