8Bitdo SNES30 GamePad - Verbindungsprobleme beim Start / Neustart



  • Hallo,
    ich verwende einen 8Bitdo SNES30 GamePad an einem Raspberry Pi 3 mit recalboxOS 4.0.0-beta6. Als Dongle wird ein CSL - USB nano Bluetooth-Adapter V4.0 eingesetzt.

    Das GamePad funktioniert soweit prima. Ich habe Probleme beim Neuverbinden, falls ich es aussschalte oder das System neustarte.
    Vielleicht mache ich ja etwas falsch, über Hilfe würde ich mich freuen.

    Wenn das System gestartet ist, Drücke ich für ein paar Sekunden die START Taste gedrückt, bis blaue Lampe blinkt. Nach kurzer Zeit leuchtet die Lampe konstant. Würde ja bedeuten, gekoppelt. Im Regelfall reagiert das System aber auf Eingaben nicht. Erst wenn ich das Pad nochmal ausschalte den Vorgang wiederhole, klappt es.
    Das passiert wie gesagt nach jedem Start, Neustart oder wenn ich das Pad ausgeschaltet habe.

    Mache ich was falsch? Wie kann ich es optimieren?

    Das 8Bitdo ist als 1. Pad eingestellt.
    Es steckt per USB als 2. Pad noch ein Buffalo Classic USB Gamepad am System.

    Über Tipps freue ich mich. Besten Dank 🙂


  • Staff
    Developer
    Team
    Global moderator
    Translator



  • Danke für den Tipp. Habe es gerade mehrfach damit versucht (Start + R).
    Damit geht bei mir leider garnix. Beide Lampen blinken aber es wird nicht gekoppelt.

    Muss dann mit nur Start ausschalten und dann mit nur Start einschalten.
    Dann nochmal aus und nochmal ein. Dann geht es erst 😩



  • Habe das selbe Problem mit gleicher Recalbox version und NES30pro controller. Wird beim 1. verbinden nicht erkannt. Hat jemand nen Tip


  • Staff
    Developer
    Team
    Global moderator
    Translator

    Wenn die Verbingun 1 Sekunde nach dem Wählen des Controllers "hergestellt" wurde, ist es tatsächlich nicht verbunden. Das Ding soll ein wenig denken (dauert!). Also, wenn das passiert, am besten Controller vergessen und neu versuchen.

    Den richtigen Modus nicht vergessen!



  • hallo, selbes problem hier, alles gleich, nur dass ich den SFC30 verwende...

    gibts da wirklich keine möglichkeit das dauerhaft zu lösen ? man findet ja genug aussagen im netz bei denen es ja reibungslos zu finktionieren scheint...

    frage an den hubi: mit usb verbunden funktioniert das 8bitdo Pad bei dir ?


  • Staff
    Developer
    Team
    Global moderator
    Translator

    @Tobias-Torggler welche Lösung soll das sein? Usern sollen sich informieren, das Gamepad mit dem richtigen Modus starten und ein kompatibles Bluetooth Dongle (4.0) benutzen. Per USB funktionieren die auch, steht in der Wiki.



  • @paradadf

    Also der dongle ist auf der kompatibilitätsliste, nach wie vor.
    Das pad starte ich genau so wie empfohlen, nach wie vor.

    Trotzdem funktioniert es mal schon, mal nicht.

    Ich hätte da gern eine lösung oder zumindest eine erklärung was da denn nun nicht funktioniert wie es soll.

    Das ist alles.

    Hab ansonsten mächtig viel spaß mit recalbox 😆


  • Staff
    Developer
    Team
    Global moderator
    Translator

    @Tobias-Torggler was passiert genau, wenn du versuchst, das Pad zu verbinden? Dauert es einige Sekunden, bis die Verbindung hergestellt wurde, oder kommt direkt die Meldung, dass das Pad erfolgreich verbunden wurde? Wie ich oben erwähnt habe, es MUSS einige Sekunden dauern, sonst ist es FALSCH "verbunden". Wenn das passiert, Bluetooth Geräte am besten vergessen, reboot und neu verbinden!
    Man kann aber auch nicht ausschließen, dass das Bluetooth Dongle das Problem ist. Neuer Firmware, falscher Eintrag, etc.
    Manche Bluetooth 2.0 Dongles funktionieren bspw. mit einigen Controllern und mit anderen nicht. Vllt ist das Dongle mit dem angesprochenen Controller nicht kompatibel... das gibt es auch!



  • hm also ich denk ich lass es jetzt so wie es ist. ungefähr jedes 2. Mal funktioniert alles wie es soll bis ich den controller wieder ausschalte, ist ausreichend fürs erste 🙂



Want to support us ?

197
Online

80.4k
Users

21.5k
Topics

157.3k
Posts