share partition problem...



  • Well, not really a problem but..

    I wanted to ask where can I find how /dev/mmcblk0p7 was mounted on /recalbox/share folder.
    I tried looking at /etc/fstab following instructions from Auto mount of usb in place of share partition (EN) but it wasn't there. I'm trying to get this to work, but something is wrong in that instructions. Starting this line: Add a # to comment the line :
    It wanted to add a # on the output of mount command?

    Anyway, I know how fstab works, and I could easily edit that to add my usb stick. But I'm curious how /dev/mmcblk0p7 was mounted on /recalbox/share. It's not in the fstab. Might be better to do the same and not mess with fstab.

    Anyone got any idea? I'm not really a linux guy... I just know some basic stuff.

    Thanks

    P.S.
    I don't want to use the "Press Start > System Settings". Because I disabled that menu for a reason that when I tried to get inside it, all I see is black screen with recalbox logo. I'm now using a bartop menu.


  • Moderator
    Team

    @reigel the mounting is handled by some init scripts, not fstab + some infos in /boot
    What are you trying to achieve ?



  • if I might "hijack" this thread I have a very similar problem: (guess you want usb, I want nas in the end it's the same, we want to manually define which device should be mounted on /recalbox/share)

    Want:
    mount nfs share as /recalbox/share to have my roms on network attached storage where they should be. (imho ;)

    works manually:
    entry into fstab:
    ip:path-to/recalbox-share /recalbox/share nfs4 rsize=32768,wsize=32768,timeo=14,intr,tcp 0 0
    and then umounting the sdcard partition and mounting /recalbox/share and then restarting the emulationstation.

    works ok with custom.sh:

    mount /recalbox/share/
    /etc/init.d/S*emulationstation restart

    but both make booting quite long and "not nice"

    I'd rather have an option to enable the fstab entry from /etc/init/S11share or the relevant conf file in /boot where you can specify ANYEXTERNAL or INTERNAL or a UUID but alas not an nfs share or telling it to use the fstab.

    so I'm a bit at a loss at how to configure it to work nicely ;) hope someone has a suggestion, thanks.


  • Moderator
    Team

    @mchack23 that's for 4.1. Meanwhile, read the wiki to know how to mound a NAS



  • @Substring
    I want to convert the share partition filesystem from ext4 to hfsplus.
    I have converted to vfat for now, but I want to allow for files larger than 4GB, while still being able to edit recalbox.conf from a jailbroken ipad.

    I inserted an hfsplus usb drive and it did not automount, but I was able to mount it manually from the command line via ssh, so the support is built in already. If I just re-format the partition to hfsplus, will it automount?
    Which script controls mounting this partition?
    Thanks


  • Moderator
    Team

    what do you mean "did not automount" ? where di you expect it to be mounted ?


Log in to reply
 

Want to support us ?

Join us on :

300
Online

27454
Users

14125
Topics

107208
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.