Ecran noir avec son sur TV CRT Philips



  • Bonjour à tous,
    je suis nouveau dans la communauté car je viens d'acquérir un RASPBERRY Pi 3 model B afin de faire tourner RECALBOX.

    J'ai suivi les étapes d'installation et j'ai réussi à faire fonctionner le système sur ma TV en hdmi.
    Maintenant, j'aimerai pouvoir le faire tourner sur ma vieille TV Philips (date de 2004) qui dispose d'une entrée video composite. J'ai donc retrouvé dans mes affaires un cable jack 3,5 avec les trois RCA jaune, rouge, blanche. Il était utilisé avec mon ancien camescope Samsung qui doit dater de 2005-2006. J'arrive en jouant avec les couleurs à avoir le son (sur le jaune et blanc) par contre je n'ai pas d'image.
    J'ai essayé diverses manipulations que j'ai trouvé sur les forums.

    1- j'ai créé un fichier config.txt à la racine de la carte microsd (
    SanDisk Ultra 16GB MicroSDHC Classe 10 FFP).
    J'ai mis dedans :

    sdtv_mode=2
    hdmi_ignore_hotplug=1

    2 - J'ai ensuite édité le fichier recalbox.conf et réglez global.videomode à default:

    global.videomode=default

    J'ai aussi commenter cette ligne :

    n64.videomode=DMT 9 HDMI

    et décommenter celle-ci :

    n64.videomode=default

    Malgré ces opérations cela ne fonctionne pas.
    Je suppose que c'est mon câble qui ne fonctionne pas. J'en ai commandé un autre sur Amazon (https://www.amazon.fr/gp/product/B003OSWZJY/ref=od_aui_detailpages00?ie=UTF8&psc=1). En espérant que cela sera mieux. N'hésitez pas à me suggérer d'autres pistes ou me dire que cela ne peut pas fonctionner sur une TV CRT ...


  • Themer

    @vince03 je ne sais pas trop où tu as créée le fichier config.txt mais de toute évidence ce n'est pas bon car celui-ci doit exister dès l'installation.

    Relis la doc wiki sur le sujet et sur comment accéder à ta recalbox en ssh ou winscp pour éditer le bon fichier

    Normalement il y a aussi une page sur comlent brancher les cables sur crt



  • @voljega Merci pour ta réponse.
    Donc oui je n'avais pas édité le bon fichier config.txt.
    J'avais lu que l'on pouvait le créer sur cette page : [http://elinux.org/FR:R-Pi_ConfigurationFile](link url) mais cela ne doit pas être adapté.

    J'ai donc revu les tutos et réussi à trouver le bon fichier dans /boot et à l'éditer avec Winscp.

    Je l'ai édité pour faire les choses suivantes :
    1-Mise en commentaire de :
    #hdmi_drive=2
    #hdmi_force_hotplug=1

    2-retrait du commentaire sur :
    sdtv_mode=2
    3-ajout de la ligne :
    hdmi_ignore_hotplug=1

    Je n'ai rien changé dans le fichier recalbox.conf par rapport à ce que je mentionnais ci-dessus.

    Et cela ne fonctionne toujours pas. Je n'ai toujours que le son. J'ai bien au démarrage des traits très rapides (1ou2) blancs qui apparaissent sur l'écrant mais je n'ai que la petite musique sans l'image.
    D'autres idées ?


  • Moderator
    Team

    Alors :

    1. la modif du recalbox.conf sera obligatoire pour le alncement des émulateurs, sinon ils se lanceront en 720p
    2. sur certains cables, l'ordre des 3 signaux n'est pas le bon. Donc tu peux te retrouver avec la video sur ce que tu pensais être du son, et vice-versa


  • Merci @subs .
    comme indiqué dans mon post, j'avais déjà modifié le recalbox.conf en faisant les opérations suivantes :
    J'ai ensuite édité le fichier recalbox.conf et réglez global.videomode à default:
    global.videomode=default
    J'ai aussi commenter cette ligne :
    #n64.videomode=DMT 9 HDMI
    et décommenter celle-ci :
    n64.videomode=default

    je disais simplement que je n'avais pas fait d'autres modifications.
    Concernant le câble, j'ai réussi à faire sortir le son sur les deux canaux en changeant le jaune et le rouge ou le blanc mais en faisant ces tests, je n'ai pas de vidéo. Donc j'attends le cable vidéo commandé (description dans mon premier post).



  • J'ai reçu mon nouveau câble et même résultat.... :-(
    J'ai aussi testé sur une petite TV avec ecran plat disposant d'une entrée composite et même topo pas d'image.
    J'ai donc décidé de tout réinstaller. Pour l'instant je suis en HDMI sur la télé du salon et bien sur cela fonctionne. Par contre j'aimerai arrivé à faire fonctionner tout cela sur TV CRT Philips.
    Je vais opter pour un cablage hdmi>VGA>Peritel... A voir si cela fonctionne car à priori c'est mieux en termes de qualité d'image.



  • Avez-vous des câbles à me conseiller ?
    1 cable hdmi-vga + 1 cable vga-peritel ?
    ou une autre combinaison ?


  • Moderator
    Team

    Att ... un truc m'échappe : quel fichier config.txt as-tu édité ??? et depuis où ?



  • @subs J'ai fait un winscp et j'ai édité le fichier config.txt dans \boot (après avoir ouvert en écriture la partition).


  • Moderator
    Team



  • Hourra !
    Cela fonctionne.
    Je suis donc reparti de zéro.
    J'ai testé les câbles avec un multimètre et cela a confirmé qu'ils étaient compatibles avec une inversion du rouge et jaune à faire.
    J'ai repris la procédure ([https://github.com/recalbox/recalbox-os/wiki/Connect-your-recalbox-to-a-CRT-with-composite-(EN)](link url)) en suivant pas à pas les modifications à faire. On était deux donc à vérifier que tout était fait correctement.
    Pour faire les modifications, j'ai fait un retour chariot+suppression de la ligne ajoutée sur chaque modification.
    Ensuite, j'ai branché tous les cables (y compris le cable crt sur la télé) et j'ai démarré la recalbox et cela fonctionne.
    Merci pour votre aide.


  • Moderator
    Team

    Super :) content que tu puisses profiter de recalbox en CRT :)


Log in to reply
 

Want to support us ?

317
Online

24340
Users

12933
Topics

97915
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.