Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

ES BlackScreen after exiting game (Sound and Menu still working)



  • Hi Comunity,

    everytime I exit a game (e.g. PS1, SNES game or Doom) I get back to the EmulationStation Window, but I only hear the music of the main menu and if I press Start or Select i see the corresponding menus. So the system is not frozen, I hear the sound and also see the menus (but with Black Background, where the Emulation Station menu should be displayed) I can restart via Menu and then everything works as expected again.

    Any suggestions, what could be the Problem? I tried to google, search Forum and Bugs, but nothing related.

    Thanks in advance and now the important details:

    RecalBox: v4.0.0-build-170 (2016/08/13 08:46)
    Board: Raspberry Pi 3 Model B
    TV: Samsung LCD connected via HDMI
    (resolutions switches from 720p (Playing games) to 1080p (Emulation Station main menu) after exit the game)

    If I can provide more information that might help, please let me know.

    BR Peter



  • which theme are you using ?



  • I'm using the standard recalbox theme which was used as default.

    But currently it seems to be fixed, I tried if the same happens when I exit the Kodi Media Center. There i got back to ES main menu as expected and now also exiting from emulatiors/games i see the menu afterwards. (And it still works after 2 hours of complete power off)

    Sorry for that, but maybe usefull for anyone who has similar issue.



  • I noticed it too. And I select blind any other game and exit this game and then everything was working.



  • someone else reported that issue. Never had it myself though



  • As I saw now that I'm not the only one having this issue. I played a little bit with the settings i tried when checking all the options after installation.
    It seems to be the "Transition Style" that is evil. (<Start> Button for Main Menu -> UI Settings -> Transition Style)
    Value "Fade" seems to work, but Value "Slide" has this BlackScreen effect. Also when having this BlackScreen and then opening the Main Menu and change the setting to "Fade", closing the Menu and then choose any Console to view the games, the display comes back. So on my system its definitly this Option.

    Hope this helps for the others having this issue.



  • Hi there,

    i've noticed the same problem today. I've updated from version 4.0.0 to 4.0.2 but that wasn't the problem.

    I also tried to configure the SNES-Emulator for using more than 2 controllers, for this i open the "Retroarch" inside of a game and just actitvated the option "Save Configuration On Exit" under Settings -> Configuration. Just after this step the problem with the Black Screen appears in every Emulator (SNES, N64, PS1...).

    I've found the solution with the "Transition Style" here, and it worked for me, but i was interested why does this problem appears.

    So i just started a SNES Game again and open the "RetroArch" menu again and just loaded the default settings from "etc/retroarch.cfg". I quit the game without the "BlackScreen"-problem. After that i switched back to "Slide" instead of "Fade" and noticed that the BlackScreen isn't appear anymore after i exit a game.

    Hope this helps!

    Greeting
    Dolo



Want to support us ?

178
Online

78.7k
Users

20.2k
Topics

148.0k
Posts