iMame4All in 4.0.0 with rPi3



  • I am running 4.0.0 beta 5 on an Pi 3. I have libretro_fba and mame2003 running, but I have several "arcade classic" roms that look like they need iMame4All to run.

    I've read through https://github.com/recalbox/recalbox-os/wiki/Advanced-Arcade-on-Recalbox-(EN) but I'm not clear on how to tell Recalbox to use iMame4All on specific ROMs in the /roms/mame/ directory. I also don't see iMame4All as a selectable emulator or core in the system. Am I missing something?


  • Moderator
    Team

    Hello

    Exemples of roms ?

    • Put only mame 0.37b5roms in mame folder /recalbox/share/roms/mame/
    • Select your rom, push select button.
    • Choose edit metadata
    • Choose emulator > libretro
    • Choose core > imame4all
    • Save
    • Play game


  • Ah - I missed that you have to set the emulator to libretro before you can select the iMame4All core.

    Ok, now that is done, new problems. Anything I try either freezes up within moments of playing or starts directly to the Retroarch menu saying "Device #0 (sdl2) disconnected".

    I've tried:

    rampage.zip
    rampage2.zip
    pacmanm.zip
    sicv.zip

    All from Mame0.37b5Roms and all on the imame4all_gamelist.txt.

    Does iMame4All not work with the Pi 3?


  • Themer

    @IOIIOOO are you 100% sure that those roms work on imame4all ?
    They might also need a bios/driver file ?



  • @voljega well they are from Mame0.37b5Roms and all on the imame4all_gamelist.txt file so other than that how would I know? And they are in a folder with all of the BIOS files listed for Mame (acpsx.zip, cpzn1.zip, cpzn2.zip, cvs.zip, decocass.zip, konamigx.zip, megaplay.zip, megatech.zip, neogeo.zip, nss.zip, pgm.zip, playch10.zip, skns.zip, stvbios.zip, taitofx1.zip, tps.zip)

    Is there a different BIOS file for iMame4All?


  • Themer

    @IOIIOOO Well where does this imame4all_gamelist.txt file come from ? And a game can be in a specific mame romset and still not be in a working state.
    Anyway the 0.78 has much more games supported.

    Regarding your bios files everything seems in order



  • @voljega It comes from /recalbox/share/roms/mame/clrmamepro/imame4all_gamelist.txt as referenced in the "Advanced Arcade on Recalbox" wiki article at https://github.com/recalbox/recalbox-os/wiki/Advanced-Arcade-on-Recalbox-(EN)

    I've tried these same specific ROMs from the 0.78 set and they don't work. That's why I'm working with iMame4All and the Mame0.37b5Roms set as referenced in the wiki article above.



  • @IOIIOOO if the 0.78 Games are not working on your PI, you definately have the wrong roms.. I myself are using the 0.78 and about 80% of the Games are working just fine. Please get the Mame2003 0.78 DAT, or the Imame4All 0.37b5 DAT and a tool like clrmamepro, or ROMulus and make yourself familiar with ROM management. After you verified the Roms you own with the DAT File(s) and they still don't work, we'll have a take a deeper look into the problem. OK? :)



  • @Nachtgarm The 0.78 ROMs from the compatible list ARE working. It's the iMame4All roms that are not.

    And I have done a scan of these using clrmamepro against the iMame4All 0.37b5 DAT. It shows that I am missing none of the expected ROMs.



  • @IOIIOOO Ok. I must've overread that fact. Sorry, for that.
    So... if the 0.78 is running, why do you want to use the 0.37 anyway?



  • @Nachtgarm Because several "classic" (i.e. older) games don't seem to want to run with 0.78. The original Pac Man, Space Invaders and Rampage are three specifically I am working on.

    On https://github.com/recalbox/recalbox-os/wiki/Advanced-Arcade-on-Recalbox-(EN) it says:

    "imame4all is recommended for older games that does not run in piFBA"

    So I assumed it's because the games are too old for more current emulators? Maybe I'm wrong?



  • I'm using the 0.78 Mame Set with the Mame emulator (mame) and it's standard settings.

    and Space Invaders (invaders.zip - MD5 9deb5c19958860d5b70e4560d2915611) is running just fine.

    Which Versions of the games are you trying to run? Zip-Name?



  • @Nachtgarm said in iMame4All in 4.0.0 with rPi3:

    Which Versions of the games are you trying to run? Zip-Name?

    I was able to get invaders.zip to run, but with no color or sound.

    I have tried:

    rampage.zip
    rampage2.zip (the 1.2 version of Rampage)
    pacmanm.zip (midway pacman)
    sicv.zip (color space invaders)

    With no success.



  • @IOIIOOO Sorry, but I wasn't able to test it further yet. I'll look into that today, most likely.



  • @IOIIOOO

    Finally, I was able to test all games. My results are:

    Pac-Man (Midway), clone of PuckMan (Japan set 1) is running just fine
    MD5: b55d6c49910c0011907dcbb78f21eaae
    File: pacman.zip

    Space Invaders has no sound, because it needs samples, which will be supported soon
    MD5: 9deb5c19958860d5b70e4560d2915611 (without samples)
    File: invaders.zip

    Space Invaders (CV Version) is not running on my Pi and if, it would need samples, too (It runs ok on my PC, minor sound issues)
    MD5: 72ff4d8d614717e6633c5bfceb0c5b4b (without samples)
    File: sicv.zip

    Rampage (Rev 2, 8/4/86) (original) is not running on my PI, nor is it running "good" on my PC (no sound)
    File: rampage2.zip

    Rampage (Rev 3, 8/27/86) (clone of Rev 2, 8/4/86) is not running on my PI, but it's running "ok" on my PC (sound probs and low framerate)
    File: rampage.zip

    I have tested all games in all available versions from sets 0.78, 0.177 and 0.37bb, but decided to write down only the essential ones


  • Moderator
    Team

    samples for mame 2003 are available in recalbox 4.0.0 b5
    need to create folder /recalbox/share/bios/mame2003/samples



  • Thanks for the heads up @acris, I confused the releases for a moment.



  • hello,

    have you find out how to get your rom working? I have the same issue as you



  • @stevex59 At this point I am giving up on getting Rampage working on my Pi3 Recalbox. Doesn't seem to be good ROMs out there. I have the original invaders.zip now working with samples, but not color. Got a pacman working.


Log in to reply
 

Want to support us ?

Join us on :

728
Online

29846
Users

14892
Topics

112146
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.