Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Can't pair bluetooth MadCatz C.T.R.L.R



  • Hi folks,

    when I try to pair the bluetooth MadCatz C.T.R.L.R gamepad I'll get the error:

    # hcitool scan
    Scanning ...
            00:15:9E:C0:78:19       Mad Catz C.T.R.L.R
    # hidd --connect 00:15:9E:C0:78:19
    Can't create HID control channel: Connection refused
    # tail -4 /var/log/messages
    Aug 16 11:28:43 RECALBOX daemon.err bluetoothd[305]: No agent available for request type 0
    Aug 16 11:28:43 RECALBOX daemon.err bluetoothd[305]: btd_event_request_pin: Operation not permitted
    Aug 16 11:28:44 RECALBOX daemon.err bluetoothd[305]: No agent available for request type 0
    Aug 16 11:28:44 RECALBOX daemon.err bluetoothd[305]: btd_event_request_pin: Operation not permitted
    

    any idea?



  • Hey !

    Does your controller require pairing with a pass ?



  • no, I don't need a key if I pair it with my phone/Android



  • it looks like it's expecting a pin, but can't interact with the user as there is no bt agent running ...



  • # sdptool browse 00:15:9E:C0:78:19
    Browsing 00:15:9E:C0:78:19 ...
    Service Name: Mad Catz C.T.R.L.R
    Service Description: HID Gamepad
    Service Provider: Mad Catz
    Service RecHandle: 0x10000
    Service Class ID List:
      "Human Interface Device" (0x1124)
    Protocol Descriptor List:
      "L2CAP" (0x0100)
        PSM: 17
      "HIDP" (0x0011)
    Language Base Attr List:
      code_ISO639: 0x656e
      encoding:    0x6a
      base_offset: 0x100
    Profile Descriptor List:
      "Human Interface Device" (0x1124)
        Version: 0x0100
    

    How would I authenticate?



  • # hcitool cc 00:15:9E:C0:78:19; hcitool auth 00:15:9E:C0:78:19
    Can't create connection: Input/output error
    HCI authentication request failed: Input/output error
    


  • so far, i have no idea on how to do that on Bluez4. Will have a look


  • Global moderator
    Team

    An idea : try an another bluethoot 4.0 dongle.



  • Howdy pals, I'm too green to understand the code you've posted, but I can tell you this. I tried my CTRLR just yesterday, and while I got nothing with it set to BT or PC modes when I set it to mouse mode the d-pad was picked up. Nothing else worked, and I wasn't asked to configure the controller, but the d-pad did work. I don't know if that helps you at all or if it's just a useless story but I figured it might so may as well share just in case.

    also, I dunno if they're different at all but my CTRLR is the one that comes bundled with the MOJO.



  • mmh. In order to get even an emulated mouse function running the device has to be paired.
    I think the gamepad should be exactly the same as yours, but I tried all three modes and it doesn't pair.
    The home button keeps blinking read and blue and nothing is working although the GUI said "ok".



  • I just tried it again. All I can tell you is exactly what I'm doing and what I'm experiencing. I have the dongle plugged in and the controller, in BT mode, on and searching before I turn on the pi. While recalbox is booting it connects, or at least stops blinking and stays blue, and after it's done booting when I slide the slider over to mouse and I can use the d-pad. At no point am I prompted to configure anything or pair anything. This time around I went ahead and tried to configure it. Nothing comes up under BT pairing and when I went to configure a controller and held down a direction on the d-pad it comes up as keyboard. I turned off the controller, and plugged it in through the micro usb port, I meant to unplug the dongle but I forgot, dunno if that matters or not. the home button went red, but I still got the same functions. on mouse mode the d-pad comes up as a keyboard. Nothing else works and nothing comes up under bluetooth.

    The only other thing I can say is I have kept my firmware up to date. if you have owned the controller for a few years without updating, updating the firmware might be why i'm getting a d-pad.

    Have you tried the moderator's suggestion? I've been trying to but I can't find any of my dongles.



  • You're completely right. I tried anothe dongle and now I have exactly the same behavior as you described.
    The interesting thing is, that the additional buttons like fastforward/fastbackward/pause and the digital arrow keys are then received as keyboard strokes and not as gamepad buttons.

    btw. my controller firmware is on latest level v1.2.5 that can be downloaded from madcatz.com



  • Guyz, seems to me it's an android pad ONLY which means it may not trigger any joypad event. Very easy to find out : once paired (in that "mouse" mode or whatever), run evtest, select your pad, foold around with the buttons. If you only get some keys starting with KEY_, you're screwed because we don't handle keyboards. Well there might be a solution with the xarcade2jstick driver, but it's very restrictive on keys it handles (MAME keys in fact).

    But if you get some BTN_ events, we could do something probably



  • evtest brings for me something like:

    Event: time 1471421830.222857, -------------- SYN_REPORT ------------
    Event: time 1471421839.037076, type 4 (EV_MSC), code 4 (MSC_SCAN), value 90008
    Event: time 1471421839.037076, type 1 (EV_KEY), code 311 (BTN_TR), value 1
    Event: time 1471421839.037076, -------------- SYN_REPORT ------------
    Event: time 1471421839.222181, type 4 (EV_MSC), code 4 (MSC_SCAN), value 90008
    Event: time 1471421839.222181, type 1 (EV_KEY), code 311 (BTN_TR), value 0
    Event: time 1471421839.222181, -------------- SYN_REPORT ------------
    Event: time 1471421839.747441, type 4 (EV_MSC), code 4 (MSC_SCAN), value 90007
    Event: time 1471421839.747441, type 1 (EV_KEY), code 310 (BTN_TL), value 1
    Event: time 1471421839.747441, -------------- SYN_REPORT ------------
    Event: time 1471421839.935186, type 4 (EV_MSC), code 4 (MSC_SCAN), value 90007
    Event: time 1471421839.935186, type 1 (EV_KEY), code 310 (BTN_TL), value 0
    Event: time 1471421839.935186, -------------- SYN_REPORT ------------
    Event: time 1471421841.059117, type 4 (EV_MSC), code 4 (MSC_SCAN), value 90008
    Event: time 1471421841.059117, type 1 (EV_KEY), code 311 (BTN_TR), value 1
    Event: time 1471421841.059117, -------------- SYN_REPORT ------------
    Event: time 1471421841.184228, type 4 (EV_MSC), code 4 (MSC_SCAN), value 90008
    Event: time 1471421841.184228, type 1 (EV_KEY), code 311 (BTN_TR), value 0
    Event: time 1471421841.184228, -------------- SYN_REPORT ------------
    Event: time 1471421850.286365, type 4 (EV_MSC), code 4 (MSC_SCAN), value 90001
    Event: time 1471421850.286365, type 1 (EV_KEY), code 304 (BTN_SOUTH), value 1
    Event: time 1471421850.286365, -------------- SYN_REPORT ------------
    Event: time 1471421850.384091, type 4 (EV_MSC), code 4 (MSC_SCAN), value 90001
    Event: time 1471421850.384091, type 1 (EV_KEY), code 304 (BTN_SOUTH), value 0
    Event: time 1471421850.384091, -------------- SYN_REPORT ------------
    Event: time 1471421851.221895, type 4 (EV_MSC), code 4 (MSC_SCAN), value 90002
    Event: time 1471421851.221895, type 1 (EV_KEY), code 305 (BTN_EAST), value 1
    Event: time 1471421851.221895, -------------- SYN_REPORT ------------
    Event: time 1471421851.320732, type 4 (EV_MSC), code 4 (MSC_SCAN), value 90002
    Event: time 1471421851.320732, type 1 (EV_KEY), code 305 (BTN_EAST), value 0
    Event: time 1471421851.320732, -------------- SYN_REPORT ------------
    

    and the button names doesn't even change when changing between the three controller modes (android/mouse/windows)
    So finally it comes down to a button name mapping issue


  • Global moderator
    Team

    This post is deleted!


  • @elchhome so it's paired, sends joypad events. If there are also mouse events sticked to it, it won't be recognized as a joypad but as a mouse. Need a udev rule. We need you to run /recalbox/scripts/recalbox-support.sh with your pad paired and upload the file somewhere. With this, we will know if your pad is seen as a mouse/keyboard or pad, and make what's necessary to have it recognised as a pad



  • I hope you can download it:
    h_t_t_p_s://drive.google.com/open?id=0BxMwQBosHAcbUUVWVkxoVkVnN2M



  • @subs
    Did you download the file and do you already have an idea how to fix that?



  • nope, didn't have the opportunity yet



  • @subs
    is there a file where I can add the button mapping by hand?



Want to support us ?

160
Online

78.5k
Users

20.1k
Topics

147.6k
Posts