Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Faire tourner des jeux comme ESP.ra.de ou Dimahoo sur récalbox ?



  • Bonsoir, j'aurai aimé savoir si quelqu'un avait réussi a faire tourner des shoot comme ESP.ra.de ou Dimahoo sur sa récalbox ? J'envisage de me faire un second bartop seulement pour les shoot verticaux et je m'interroge sur les possibilités de portages. Merci !


  • Staff
    Moderator
    Team

    Bonjour tu possèdes donc déjà un bartop peut etre sous recalbox, ce sont des jeux mame arcade, donc je pense que tu peux tester ses deux jeux non ? dimahoo de mémoire fonctionne sous fba libretro. je ne vois pas pourquoi il serait question de portage... Ma culture arcade est proche de -1 peut être que @voljega, @ironic, @gkralicek pourront te dire. En attendant tu peux consulter cette doc : https://docs.google.com/spreadsheets/d/1F5tBguhRxpj1AQcnDWF6AVSx4av_Gm3cDQedQB7IECk/edit#gid=423376617



  • Justement, je n'arrive pas faire tourner ces titres sous mame ou fba...ma question est donc: est il possible de les faire tourner? Quelqu'un a t il les bons roms? Sinon tant pis,je me tournerai vers une configuration PC avec Hyperspin...


  • Staff
    Moderator
    Team

    Ses deux jeux fonctionnent sur fba libretro, maintenant à toi de trouver le bon romset fba libretro correspondant à celui de recalbox ou autre et de faire l'adaptation via le fichier dat fourni avec clrmamepro ou équivalent. sur le net ce n'est pas difficile de trouver : ARCADE ROMSET FBA LIBRETRO 0.2.97.38 COMPLETE https://github.com/recalbox/recalbox-os/wiki/L'arcade-avancée-sur-Recalbox-(FR) https://github.com/recalbox/recalbox-os/wiki/Vérifier-la-version-de-vos-roms-avec-clrmamepro-(FR)


  • Banned

    Oui les deux fonctionnent (ptet pas parfaitement niveau vitesse pour le deuxième je ne me rappelle plus...)



  • Bonjour à tous, Bon pour ma part, je suis passé à la beta4 et je ne vois pas de souci avec mon Romset FBA LIBRETRO 0.2.97.37 ... Faut-il changer ??? Je pensais que le core 38 serait seulement pour la 4.1, je me trompe ? Il vaut mieux déjà prévoir le FBA LIBRETRO 0.2.97.38 ou ça ne change rien ? Luckiest


  • Staff
    Moderator
    Team

    Oui le core sera mis à jour pr recalbox 4.1.0 mais le romset 0.38 devrait passer av la version actuelle.


  • Banned

    Il y a très peu de changement actuellement dans Mame sur les jeux 'historiques' donc les jeux continuent à fonctionner beaucoup plus longtemps qu'avant même qd les romset changent de version.   A vrai dire on pourrait dire que Mame n'évolue plus du tout depuis un an et demi et peut même limite être considéré comme mort mais c'est un autre sujet



  • Ok , merci bien je vais voir pour modifier mon romset. J'ai une autre question cette fois concernant la conception même du bartop vertical: Est ce que l'affichage vertical pourra se faire en plein écran ? (J'envisage d'y mettre un écran 22 pouces 16/9) Merci


  • Staff
    Moderator
    Team


  • CRT Maniac

    Comme le dit @ Acris, pour les jeux verticaux, le sujet d'au dessus est très intéressant. Pour ESP Ra.De. et Dimahoo, ils tournent parfaitement sous FBA LibRetro 0.37, je viens de retester à l’instant. Son sans craquement et animation a 60Hz sans ralentissement. Chez moi ça tourne en 768*1024 avec shader scanline et lissage (Rpi2 a 1100Mhz). Si tu utilises un écran verticalement et donc une plus grande résolution, ça pourrait éventuellement ramer un peu)



  • j'ai lu avec attention le topic....du coup j'hésite! Sinon c'est bon ESP.ra.de et Dimahoo tournent parfaitement sur mon bartop! Je n'arrive cependant pas à faire tourner Dragon Blaze malgré plusieurs versions essayées...et vous ?


  • Staff
    Moderator
    Team



  • Merci Acris mais j'ai déjà parcouru ce topic en long et en large. DragonBlaze se lance mais le son est horrible et il saccade horriblement. J'ai essayé  un nombre incroyable de versions de roms différentes ...


  • Banned

    Ben ça sert à rien de changer de versions de rom hein...


  • Staff
    Moderator
    Team

    Effectivement et sous fba libretro 0.38 c'est pire. Il y a une solution pour ajouter le core fba 0.30 ou 0.34 qui est compatible avec les psikyo , l’inconvénient est qu'à chaque mise à jour il faudra de nouveau faire les modifications. (sans shooter configgen pour la gestion...;P)


  • CRT Maniac

    La rom de DragonBlaze sous toutes les versions de FBA est la même. Inutile d'en essayer 36. Sous Rpi2 a 1100Mhz avec FBA 0.34, le son est très bon.

    (sans shooter configgen pour la gestion…;P)

    Lol, effectivement, chez moi, tous les Psikyo se lancent avec FBA 0.34 mais ça nécessite une "grosse" modif de script.


  • Staff
    Moderator
    Team

    Je donnerai lastuce demain pur ajouter fba 0.34.


  • Staff
    Moderator
    Team

    Bonjour voici comment ajouter le core fba libretro dans emulationstation.
    Attention cette manipulation devrait être effectuée à chaque mise à jour de recalbox car le fichier es_systems.cfg est mis à jour. Télécharger le core fba : /FBA/fba_libretro_0.2.97.34.so https://mega.nz/#F!oJJnxJSQ!Xo5q0lABO9WPEZa8ee7v3A (merci @ironic pour le partage)
    Personnellement je l'ai renommé en fba.034_libretro.so
    Monter la partition en écriture via SSH/Winscp : mount -o remount,rw /
    Copie le fichier fba.034_libretro.so dans /usr/lib/libretro/
    Editer le fichier /recalbox/share_int/.config/.emulationstation/es_systems.cfg
    Ajouter cette ligne <core>fba.034</core> dans la section fba libretro comme ceci

    <system>
            <fullname>FBA LIBRETRO</fullname>
            <name>fba_libretro</name>
            <path>/recalbox/share/roms/fba_libretro</path>
            <extension>.zip .ZIP .fba .FBA</extension>
            <command>python /usr/lib/python2.7/site-packages/configgen/emulatorlauncher.pyc %CONTROLLERSCONFIG% -system %SYSTEM% -rom %ROM% -emulator %EMULATOR% -core %CORE%</command>
            <platform>arcade</platform>
            <theme>fba_libretro</theme>
    	<emulators>
    	    <emulator name="libretro">
    	        <cores>
    		    <core>fba</core>
    		    <core>fba.034</core>
    		</cores>
    	    </emulator>
    	</emulators>
        </system>
      <system>
    

    Enregistrer puis redémarrer
    Sur chaques jeux psikyo dans fba libretro. Selectionner le jeu puis Bouton select puis editer les données du jeu dans :
    emulateur mettre libretro
    core mettre fba.034
    sauvegarder et jouer !
    Répéter pour chaque jeu de la liste.
    La méthode fonctionne aussi pour ajouter d'autres cores fba.030 suffit d'ajouter une nouvelle ligne.
    Remarque : les dipswitches ne sont pas disponible avec ses cores (introduit en 0.36 ou 0.37)
    Les jeux d'un romset fba 0.2.97.37/0.2.97.38 sont compatible avec les cores inférieurs pas besoin de downgrader.



  • Ces deux jeux tournent parfaitement sur Pi3 et Libretro.



Want to support us ?

167
Online

62446
Users

18673
Topics

140237
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.