[Solved]RPI 3 + TPLINK WN822N, cannot connect to wireless



  • Hello All, I happily got set up a new RPI 3 Model B for my wife as her birthday gift, with Recalbox. Unfortunately, the Kodi experience was sub par because it's so far away from the router and the built in WiFi wasn't strong enough.   Looking through the wiki, I ordered a TP-Link WN822N, listed on the compatibility list. https://github.com/recalbox/recalbox-os/wiki/Compatibility-(EN) It is a V3 model, based off the Realtek RTL8192CU chipset. (The same chipset that the recommended Wifi Adapter from the RPI's main site.). I hooked it up to the RPI after powering down, booted up...and now I cannot connect to my network. Things I've checked:

    • I'm running the newest Recalbox 4.0.0 Beta3 for RPI3.
    • I'm using a non-hidden SSID with no special characters
    • I use WPA2-PSK, but disabled the password to test with no difference
    • I have ensured the device works on windows.
    • I can disconnect the WN822N v3, and the integrated wireless adapter will again connect to the network fine .
    • I reimaged the RPI3 with LibreElec, and the Wireless adapter works out of the box. Same for RetroPIe.

    I'm out of ideas on what could be causing this. Is there some sort of manual driver load that would be needed for Recalbox that's not needed for LibreElec or RetroPIe? If the 4.0.0 Beta 3 differen't than the 4.0.0-Dev listed within the compatibility list?   Any and all help is greatly appreciated.   Thanks, -Silver


  • Staff
    Global moderator
    Team

    Hello sorry for my english : you must blacklist wifi in RPI3 to use wifi dongle in recalbox 4.x Sorry in french https://github.com/recalbox/recalbox-os/wiki/blacklist-wifi-rpi3-(FR) but you read command line



  • Thank you greatly. This worked perfectly.   Do I have the ability to make an english version of this page?  If not, could someone make one? I think it'd be useful to have in the documentation.



Want to support us ?

340
Online

81.4k
Users

22.3k
Topics

161.5k
Posts