[Solved]Automount for cifs shared folders not working?



  • Hi I'm trying to configure my Recalbox to mount several shared folders at boot. I've edited /etc/fstab but after rebooting the folders are not mounted and I can't access them. I can when I mount them manually, but the fstab file seems to ignore my shared folders. An example line for my fstab: //192.168.1.100/Pelis /mnt/pelis cifs username=user,password=pass,_netdev,iocharset=utf8,x-systemd.automount,noauto,sec=ntlm 0 0 I've read somewhere than on Raspbian you can configure a "Wait for network" boot option so network drives can be detected (with raspi-config) but that tool is not present on Recalbox and I don't see the way to add that option on Recalbox config files. Could someone help me with this? Regards!


  • Staff
    Global moderator
    Team

    Hello

    username=user,password=pass

    do not forget to replace user and password with your own Check this page : https://github.com/recalbox/recalbox-os/wiki/Load-your-roms-from-a-network-shared-folder-(EN)



  • Yep, I knew that, I didn't want to put there my real username and password. The link you gave did work. Three differences from what I was doing: 1. The mount line on /etc/fstab uses "user", not "username" 2. I had to add the 'mount -a' option to nano /etc/init.d/S31emulationstation 3. I had to do a 'mv /etc/init.d/S31emulationstation /etc/init.d/S92emulationstation' in order to set that file as the one to boot from and mount everything. Solved! Nice 😉 Thanks!



Want to support us ?

280
Online

81.4k
Users

22.2k
Topics

161.3k
Posts