Eviter le resize sur les emulateurs



  • Salut à tous' Est il possible d'éviter que les émus fassent un redimensionnement de l'image à l'affichage ? Je veux dire, si mon jeu a une résolution originelle de 384x224 pixels, je veux qu'il s'affiche en 384x224 même si mon écran est plus grand ou plus petit. C'est pour un usage spécifique. Merci à tous ! A+


  • Staff
    Global moderator
    Team

    Bonjour ce n 'est pas si simple que ça. Un peu de lecture pour t'aider : https://github.com/recalbox/recalbox-os/wiki/Video-configuration-detailled-(EN)



  • Salut, Merci pour ta réponse et ton lien, mais ce n'est pas tout à fait ce que je cherche. Mon mode vidéo est déjà configuré et fonctionne. Je veux "juste" que les émulateurs ne redimensionnent pas l'image à la taille de l'écran. A bientôt


  • CRT Maniac

    Quelle est la résolution de ton écran ?

    Je veux dire, si mon jeu a une résolution originelle de 384×224 pixels, je veux qu’il s’affiche en 384×224 même si mon écran est plus grand ou plus petit.

    • Ça veut dire que t'as un écran de 384x224 pixels natif ? "Même si mon écran est plus petit" : Ça veut dire qu'il va te manquer un partie de l'affichage du jeu ! "Même si mon écran est plus grand" : Si ton écran est un full HD, tu vas avoir un timbre poste sur ton écran. Donne nous des détails, explique-nous exactement ce que tu fais et ce que tu veux.... - Tu veux l'Aspect Ratio parfait ? - Des tailles de pixels entiers ? - Un scanline sans défaut ? Sinon, RetroArch propose cette option : - Settings/Video/Integer Scale : ON - Custom Ratio : 1x1 Si tu fouilles le forum, j'ai abordé à plusieurs reprises les résolutions natives d'écrans, de jeux, les proportions...


  • Salut, Merci de ta réponse, je vais regarder la config sur retroarch comme tu proposes, une fois que j'aurais récupéré une manette adéquate (j'ai tenté de rajouter aspect_ratio_index = "20" dans retroarchcustom.cfg mais ça ne fonctionne pas) L'écran fait 320x240 et je veux un pixel perfect quitte à perdre quelques pixels. A bientôt


  • CRT Maniac

    Si ton jeu fait 384×224 et que tu as un écran de 320x240, tu ne peux pas utiliser l'Integer Scale. Il faut que ton jeu fasse 320x224. Dans ce cas la, ton CFG de RetroArch doit avoir ces paramètres : aspect_ratio_index = "22" custom_viewport_width = "320" custom_viewport_height = "224" custom_viewport_x = "0" custom_viewport_y = "8" A noter que sur les CRT d'arcade, les pixels ne sont pas 1:1 Exemple, un jeux utilisant un écran vertical de 4/3 peut être en plein écran avec une résolution de 320x224, 320x240, 384×224, 384×240... Pour avoir l'Aspect Ratio parfait et un pixel 1:1 sur un écran LCD, c'est...impossible. Le Pixel Perfect te permet d'avoir un scanline également parfait. La résolution ne fait pas tout. Si ton écran ne peut pas descendre en dessous de 60Hz (par exemple, 50Hz), tu risques d'avoir pas mal de jeux PAL qui saccadent.



Want to support us ?

336
Online

81.4k
Users

22.2k
Topics

161.4k
Posts