GPIO raspberry pi 3 recalbox 4 beta 3



  • Bonjour à tous, Voilà j'ai construit ma borne, elle a tourné un certain sous rasp pi 2 et recalbox, mes boutons étaient connectés sur le GPIO et tout allait bien ! :) J'ai acquis un Rpi 3, j'ai installé recalbox 4 beta 3, j'ai branché mes boutons sur le GPIO à l'identique du précédent, j'ai activé le GPIO dans recalbox.conf sauf que quand je démarre un certains nombres de boutons ne fonctionnent pas. Je joy 1 et le boutons du joueur ne fonctionnent pas, certains du joueur 2 non plus ! J'ai essayé de "configurer la manette" mais les bontons ne semblent pas détecté alors qu'il m'indique "2 gamepads détectés". Une idée ? le GPIO n'est pas le même sur le Pi2 et Pi3 ? il y a une manip' à faire en plus ? je ne me souviens plus des différentes étapes que j'avais fait sur la Pi 2 ! :) Merci


  • Moderator
    Team

    Bonjour as tu bien fait tes branchements ? as tu vérifié avec un jstest ou evtest. peux tu créer l'archive ce cette page et la poster : https://github.com/recalbox/recalbox-os/wiki/Recalbox-support--(FR)



  • Bonjour,   Oui les branchements semblent bon (en tout cas identique à ma Rasp pi 2) ! Le jstest fonctionne partiellement, les 2 joueurs sont détectés, mais ensuite certains boutons fonctionnent, d'autres non... voici le lien pour récupérer l'archive : http://dl.free.fr/hYAzyh64F Merci


  • Moderator
    Team

    Bonjour Martin @carlux3 recontrole tes branchements et ta masse ça ressemble à un problème hardware et non software.



  • Je ne vais pas pouvoir vérifier avant le début de semaine prochaine. Mais pour m'ôter tout doute les gpio sur rpi 2 et rpi 3 sont bien identique ? merci



  • Oui c'est les même.


Log in to reply
 

Want to support us ?

Join us on :

305
Online

27411
Users

14113
Topics

107101
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.