N64 problem with old monitor



  • I've got Recalbox running nicely with N64 games on my main computer monitor, but when I use an old Dell monitor (via a HDMI to DVI or a HDMI to VGA cable as it doesn't have an HDMI input) N64 games don't run. I get the Recalbox logo then a few seconds later it returns to the N64 Emulationstation menu. I've tried setting the video modes are suggested here: https://github.com/recalbox/recalbox-os/wiki/N64-%3A-return-to-ES-(EN) I've also tried the different video plugins rice and n64 (selected via Emulationstation). Any suggestions on what to try next, or where to check for error logs? All I change between it running and not running is the monitor and monitor cable. I really would like to get it going with this old Dell monitor as it's part of an arcade machine I've made - so not easy to change for another type.



  • I have this same problem with the Raspberry Pi official 7" screen connected via the dsi cable. as soon as the game is selected it goes back to the black recalbox screen


  • Moderator
    Team

    Hello for hdmi/vga -> https://github.com/recalbox/recalbox-os/wiki/Connect-your-recalbox-to-a-DVI-screen-(EN) in recalbox.conf : https://github.com/recalbox/recalbox-os/wiki/recalbox.conf-(EN) modify this line : global.videomode=CEA 4 HDMI into global.videomode=default save file and reboot your rpi read this too : https://github.com/recalbox/recalbox-os/wiki/Video-configuration-detailled-(EN) your roms must be in *.n64, zip archive is not supported



  • Thank you Acris!   I also found the readme file in n64 rom directory which addresses this issue too::   -------------------------------------------------------- ## RECALBOX - SYSTEM N64 ## Put your nintendo 64 roms in this directory. Rom files must have a ".n64/.v64/.z64" extension. You can download n64 roms on xxxxxxxx If you have problems about black screen with return to Emulationstation, please read wiki below : https://github.com/recalbox/recalbox-os/wiki/N64-%3A-return-to-ES-(EN) --------------------------------------------------------



  • update - i tried setting global.videomode=default   this didnt work. I also realized that i went though the other link from the read me a while ago, but the problem is that I get 0 modes when I use tvservice -m DMT and tvservice -m CEA to redescribe - i start a game through emulationstation it goes to the black screen with the Recalbox logo at the bottom. then it just back to emulationstation.  the other games that work on snes for example, will show the same black splash screen then load the game.   <span style="font-family: Inconsolata, Consolas, Monaco, 'Lucida Console', monospace; font-size: 1em; color: #737c85; line-height: 26px; background-color: #f9f9f9;"> </span>


  • Moderator
    Team

    Do you have configure L1 R1 L2 R2 Buttons of gamepad ? N64 needs them.



  • I will check tonight (in ~8 hours) to be sure they are mapped. the controller has them physically so i thought i had them mapped.   Thanks again Acris!



  • An update from the original post: The emulator works with both my HDMI monitors, both directly via HDMI and via a VGA or DVI adapter. MAME works OK. It doesn't work with the old Dell monitor despite trying the video modes in recalbox.conf which are supported with the tvservice command. I've tried other video configurations in config.txt too. I ran into problems with dual xin-mo joysticks on MAME with Recalbox so I've decided to stick to Raspicade for the arcade machine and use Recalbox with a spare monitor for N64 games.


Log in to reply
 

Want to support us ?

Join us on :

170
Online

28963
Users

14702
Topics

111010
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.