Composite Video



  • Hy, sorry for my bad english. I try to build a gameboy with my RPI3. I start a game, no matter is it a gameboy,playstation..... game. When i connected my RPI with HDMI at my TV every game starts, but when i changed to the composite output i can switch to the game and can press Start and then i get a black screen. I restart my PI and everything is ok only when i change to KODI or try to start a Game. I hope someone understand what i mean and can help me.





  • Hi there. Have problems with my Raspi3 and Compsite out too. Changed everything in the configs like in https://github.com/recalbox/recalbox-os/wiki/Connect-your-recalbox-to-a-CRT-with-composite-(EN) described. But the black screens ist always there. Cant see RecalBoxOS Boot, nor the ES Emuscreen and so on. Please help!   Thanks



  • Hi, may you copy your full config.txt file please?



  • Here it is: # uncomment if you get no picture on HDMI for a default "safe" mode #hdmi_safe=1 #disable_overscan=1 # uncomment to force a specific HDMI mode (this will force VGA) #hdmi_group=1 #hdmi_mode=1 # comment to get jack audio hdmi_drive=2 config_hdmi_boost=0 # force hdmi while the tv can take time before sending the signal on the hdmi output hdmi_force_hotplug=1 # uncomment for composite PAL sdtv_mode=2 hdmi_ignore_hotplug=1 # uncomment for lirc-rpi #dtoverlay=lirc-rpi # if you plug your tv at the same time as your rpi and that the rpi switches from the hdmi or give a low resolution because tv had no enough time to initialize it boot_delay=3 # uncomment if you don't want the rainbow at startup disable_splash=1 # Overclock gpu_mem_256=128 gpu_mem_512=256 gpu_mem_1024=512 avoid_safe_mode=1 kernel=zImage # NOOBS Auto-generated Settings: hdmi_force_hotplug=1



  • Ok, i tried some modifications and now it works for booting the Recalbox Menu. BUT: i tried to start a Game (here: the Demogame for SNES). AND: The screen is again black! Any Ideas? Here ist the modified config.txt # uncomment if you get no picture on HDMI for a default "safe" mode #hdmi_safe=1 #disable_overscan=1 overscan_left=-14 overscan_right=-24 overscan_top=-28 overscan_bottom=-20 # uncomment to force a specific HDMI mode (this will force VGA) #hdmi_group=1 #hdmi_mode=1 # comment to get jack audio #hdmi_drive=2 #config_hdmi_boost=0 # force hdmi while the tv can take time before sending the signal on the hdmi output #hdmi_force_hotplug=1 # uncomment for composite PAL sdtv_mode=2 hdmi_ignore_hotplug=1 # uncomment for lirc-rpi #dtoverlay=lirc-rpi # if you plug your tv at the same time as your rpi and that the rpi switches from the hdmi or give a low resolution because tv had no enough time to initialize it boot_delay=3 # uncomment if you don't want the rainbow at startup #disable_splash=1 # Overclock gpu_mem_256=128 gpu_mem_512=256 gpu_mem_1024=512 avoid_safe_mode=1 kernel=zImage # NOOBS Auto-generated Settings: #hdmi_force_hotplug=1



  • Edit your recalbox.conf file then switch global.videomode=CEA 4 HDMI to global.videomode=default



  • Thanks, forgot to tell. And yes, its starts perfect and shows the menu now on Composite. BUT: After starting an emulation, the screen went black again...



  • If you are in recalbox v4.0.0 beta, can you start this script /recalbox/scripts/recalbox-support.sh and give me this generated archive.


Log in to reply
 

Want to support us ?

301
Online

81.4k
Users

22.2k
Topics

161.3k
Posts