Changement dé résolution



  • Bonjour à tous ! En qualité de noob sur recalbox, j'ai besoin de vos lumières. Je voulais savoir si il était possible d'ajouter une résolution. En effet lorsque je fais : tvservice -m DMT (écran connecté en dvi sur un écran pc via un adaptateur), je n'ai qu'un mode :

    mode 4: 640x480 @ 60Hz 4:3, clock:25MHz progressive. 
    
    Mon écran supporte pourtant le 1600x1200 (

  • Moderator
    Team

    Bonjour tu es sûr d avoir qu un seul mode ? peux tu si tu es en recalbox.4.0.0 réaliser l archive demandé par ce sujet : https://github.com/recalbox/recalbox-os/wiki/Recalbox-support--(FR) as tu simplement aussi régler la sortie video sur ton écran ?



  • Sûr et certain de n'avoir qu'un mode. Comme dit,j'ai de l'affichage, ça fonctionne mais je suis étonné de voir que je n'ai qu'un mode. D'après le wiki je devrais en avoir plus et j'aimerais aussi utiliser le meilleurs affichage pour mon écran. Voici l'archive : http://dl.free.fr/gE9bYwH7b


  • Moderator
    Team

    as tu simplement aussi régler la sortie video sur ton écran ?



  • Je m'excuse mais je ne comprend pas la question. Je suis en dvi D et dans le menu de l'écran je ne vois pas de réglage de résolution.


  • Moderator
    Team

    Sur un ecran LCD tu as un menu avec parfois un mode daffichage. Sur celui que j'ai actuellement un samsung syncmaster 191T j appuie sur le bouton menu je vais mode affichage et ça m indique 1280x1024 digital as tu regardé dans les réglages de ton écran ? as tu regardé avec un autre adaptateur hdmi dvi ou hdmi vga ?



  • Oui, j'ai bien  tout regardé. J'ai l'info affichage qui m'indique ma résolution actuelle (celle qui apparaît donc dans tvservice) et l'optimale ( 1600x1200 que j'aimerais). Et aucun changement de possible. Je n'ai actuellement aucun autre adaptateur HDMI DVI. Cela pourrait provenir de la?


  • Moderator
    Team

    je ne suis pas une spécialiste vidéo peut être que @rockaddicted ou @retroboy auraient une explication.



  • Merci de ton aide en tout cas ! J'ai testé avec raspbian et cela m'indique la même chose. Je m'interroge donc sur l'adaptateur


  • CRT Maniac

    Pas grave si tvservice ne te donne pas les bonnes infos. La meilleurs chose a faire c'est d'essayer. C'est surement ton adaptateur, le probleme. Tente un : hdmi_mode=51 1600x1200 60 Hz (global.videomode=DMT 51 HDMI). C'est quoi ton adaptateur ?



  • Bonjour, je suis entrain d'essayer un autre adaptateur, je re testerai le mode 51 quand même (j'avais fais quelque recherches mais rien ne semblait marcher. je vous tiens au courant ! et l'adaptateur c'est celui ci : Adaptateur HDMI DVI Edit : j'ai testé un nouvel adaptateur, pareil ! mais sur un autre écran j'ai les différents mode DMT. J'ai mide le mode 51 dans recalbox.conf, rien n'a changé, j'ai toujours du 640x480! C'est pas très joli! Du coup ce serait l'écran qui n'envoie pas un bon signal?


  • Moderator
    Team

    Toujours un autre adaptateur hdmi dvi ?



  • Oui, c'est un autre adaptateur que j'ai testé sur un autre écran ou la, tvservice m'affiche les résolutions et je le vois a l'oeil que c'est plus net (meilleur résolution). Je ne vois pas pourquoi l'écran que j'ai poserait problème. je suis un peu perdu !


  • Moderator
    Team

    @ironic aura peut etre une idée du problème il maitrise bien l histoire des résolutions écran :D


  • CRT Maniac

    Pour moi, un adaptateur HDMI vers DVI-D ou DVI-D vers HDMI ne peu pas poser de probleme. Ce sont les même signaux. Ce n'est pas un convertisseur mais bien un adaptateur physique. Sans entrer dans les details, les 2 différences entre le HDMI et le DVI-D c'est le format physique du connecteur et l'absence de son dans le DVI-D. Si tu forces le 1600x1200, ça devrait fonctionner. Après, t'es pas a l’abri d'une particularité qui empercherait cette résolution.

    J’ai mide le mode 51 dans recalbox.conf

    Ce paramètre est utilisé pour les émulateurs, pas pour EmulationStation, Si tu veux EmulationStatiuon en 1600x1200, Essais de modifier le fichier "/boot/config.txt" et mettre : hdmi_group=2 hdmi_mode=51 hdmi_drive=2 hdmi_force_hotplug=1 config_hdmi_boost=4 Si tu vois plus le Boot de Noobs, appuies sur "Shift" au démarrage pour avoir le mode vidéo de base et remodifier "/boot/config.txt".



  • Pour le moment, je n'ai aucun changement. voici ce que j'ai modifié dans le config.txt : #hdmi_mode=51 1600x1200 @60Hz et dans la partie global emulator configuration de recalbox.conf: global.videomode=DMT 51 HDMI Dites moi si je me suis trompé quelque part.



  • @ Ely Jun,   essaie  : hdmi_mode=51 dans le fichier config.txt le # désactive la ligne



  • Toujours la même résolution. Par contre quand je lance un jeux, il me dit, signal déphasé, impossible d'afficher ce mode vidéo, changez l'entrée d'affichage de l'ordinateur à 1600x1200 @ 60Hz Et quand je veux revenir au menu, écran noir (la recalbox tourne encore j'entend le son)



  • tu trouveras peut-être une réponse sur ce site. https://www.raspberrypi.org/documentation/configuration/config-txt.md



  • Bonne nouvelle, la résolution est maintenant bonne. J'ai fais mon noob, je n'avais pas enlevé le # devant hdmi_group. La mauvaise nouvelle c'est que mon signal est maintenant déphasé lorsque je lance un jeu. Même message lorsque je reviens au menu.


Log in to reply
 

Want to support us ?

Join us on :

356
Online

31149
Users

15125
Topics

113800
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.