Moonlight : écran noir après lancement



  • Bonjour, Je me permet de vous contacter pour savoir si vous avez une solution pour moonlight. J'ai bien suivi le tuto, mes jeux sont scrappé et apparaissent dans l'onglet moonlight sur recalbox. Si je lance Steam ou un autre jeu à partir du menu du raspberry, cela fait un écran noir. Par contre le jeu se lance bien sur le pc quand je contrôle. J'ai bien configuré ma manette xbox 360 filaire. Je précise que j'ai installé la dernière version beta de recalbox.   Avez vous une solution pour ce problème? Merci de vos retour.



  • Bonjour, Je me permets de m'inviter sur le topic car j'ai le même soucis. Moonlight a fonctionné quelques jours puis écran noir. J'utilise un Rpi3 et deux manettes 360 sans fil configurées. Les deux changements qui peuvent expliquer le plantage : j'ai peut etre ajouté une manette (mais les deux sont configurées) Les mises a jours Nvidia sont automatiques chez moi et il y en a eu une... Même symptomes : ecran noir sur TV, l'ordi lance steam mais la manette ne réagit pas, obligé de rebooter le pi. Question bonus : y a t il un moyen de faire tourner steam en fond de tache et non en plein écran pendant le streaming ?!?   Merci a vous !


  • Moderator
    Team

    Bonjour @subs (dev qui a fait lintégration de moonlight) dès son retour de vacances pourra vous aider patienter.



  • Alors moi je dis @subs : bonne vacances et profite !!! Nous serrons patients, promis !!!



  • @tony59 @MrTom vos ecrans sont en quelle resolution ? regardez s'il supporte bien la résolution indiquée dans /recalbox/share/configs/moonlight/moonlight.conf Pour steam : c'est forcément du plein ecran, ca ne dépend pas de moi mais des pilotes nvidia qui fonctionnent de la sorte



  • @Subs Bonjour, mon écran est en 720p. Mais que je modifie pour faire en 720 ou 1080 dans le fichier de résolution le soucis est pareil. Je précise que j'ai déjà réussi à lancer steam pour essayer mais plus moyen depuis.   Merci



  • Je suis en 1080 aussi, le fichier conf semble ok, steam a bien fonctionné les premiers jours mais plus rien...



  • @tony59 @MrTom Vous etes bien en GFE 2.10 ? Vous n'avez pas uppé en GFE 2.11 entre temps ?



  • Je vais vérifier ça en rentrant chez moi dans la journée. J'ai une fâcheuse habitude à faire toutes les mises à jours nvidia... Je sais que j'ai fait une maj entre le moment où moonlight fonctionnait et où il a cesser de marcher. (@subs : 6h43 sur le forum d'accord mais pendant les vacances... ?)



  • 2.11.2.55 pour moi... je vais essayer de réinstaller la 2.10



  • mon message précédent n'est pas passé.. J'ai réinstallé la version 2.10 mais mise a jour des driver nvidia auto... malgré le fait d'avoir décoché la case "MAJ auto" je suis automatiquement en 2.11... je vais tenter de désinstaller la suite complète nvidia et pas que GFE pour voir...



  • Hello, Y a t il un moyen de faire fonctionner moonlight avec GFE 2.11 ?


  • Moderator
    Team

    seul @subs pourra dire si moonlight a été mis à jour ou non



  • @mrtom il faut passer sur moonlight 2.2.0 pour çà. Le problème est qu'il utilise une nouvelle bibliothèque réseau et depuis il ne compile plus. J'ai commencé à regarder, mais pas encore réussi Tu dois rater un param de config pour GFE s'il se remet à jour tout seul ...



  • Décidément... je désinstalle GFE2.11 (seulement GFE) puis réinstalle la 2.10. Dès que je redémarre l'ordi, au lancement de GFE, j'ai une mise a jour auto. Peut être devrai je désinstaller toute la suite Nvidia et remettre les anciens drivers... Pour l'instant, pas tellement le temps donc je mets en standby moonlight. @subs y a t il un moyen d’être tenu informé de l'avancé de tes travaux ? en tout cas, un grand merci a toi... et un immense bravo pour le taff accompli !



  • @mrtom j'étais dessus hier quand qqu l'a corrigé. La pull request est faite par un contributeur externe, ca compile, je dois encore tester si c'est bon avec recalbox. Pour la prochaine version de la 4.0.0 si tout va bien


Log in to reply
 

Want to support us ?

Join us on :

203
Online

30915
Users

15092
Topics

113618
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.