Trouble mounting NFS share



  • Hi everyone. First post here. I am a noob to linux and recalbox but am learning quite a lot. I've got my raspberry pi 2 w/Recalbox 4.0 up and running with playing ROMs locally, but now I want to try and play them from my BanaNAS file server, specifically via NFS. I have already configured the NFS server and it works great on my other devices; accessing the NFS share through Kodi. Come to think of it, I CAN access the NFS server on the rpi2 through Kodi, but that's it. I've tried following the guides on github, HTPCGuides, and even this guy's blog, but I can't get past the step where I mount the NFS share to recalbox. Below are some of the mount commands I've tried with their respective errors (I apologize ahead for not putting them neatly in those command box thingies I see other people do; not sure how to do that yet): # mount 192.168.0.123:/media/partition2/multimedia/roms -o user=XXXX,password=XXXX /recalbox/share mount: mounting 192.168.0.123:/media/partition2/multimedia/roms on /recalbox/share failed: Invalid argument - then I tried without the user/password option: # mount 192.168.0.123:/media/partition2/multimedia/roms /recalbox/share         mount: mounting 192.168.0.123:/media/partition2/multimedia/roms on /recalbox/share failed: Connection refused   <---(this takes a long time and looks like it may work but ends with this error) There was one other command I tried (can't remember exactly what I changed) that resulted in an error similar to "numerical result out of range". I've even tried creating a temporary /mnt/share folder with "777" permissions, but I still get the same errors above. So obviously I'm missing something (probably super easy if I knew what I was doing). I find it kind of interesting how the NFS works through Kodi but not through the base system. Any help is greatly appreciated. Let me know if any further info is needed. Thank you! EDIT: I just read that in order to use roms stored on external media, said media needs to be formatted as FAT32. Is this the same for network shared media? Because my NFS share is formatted as ext4



  • Hey,

    It's a question that I asked myself often.
    Have you find an answer ?



  • Bump.

    Also my first post here. I've been eagerly awaiting the new version of Recalbox, and was excited to finally give it a try. The feature I was waiting for was the ps3 controller bluetooth, but I haven't even looked at that yet: all of my roms are on an nfs share on my gentoo box, which is the core of my network. I can gracefully mount them in RetroPie, so this should work in theory, but RecalBox 4.0.2 doesn't seem to boot after making the necessary modifications to fstab as per the git guide.

    Obviously, my nfs drives are linux native partitions (ext4). Is RecalBox restricted to fat32 filesystems when mounted in this way, as this thread would imply?

    Cheers,
    ~g


Log in to reply
 

Want to support us ?

411
Online

81.3k
Users

22.2k
Topics

161.1k
Posts