Recalbox 7.0

Castlevania Aria of Sorrow stalls - Game Boy Advance



  • Hi, I've been trying to play "Castlevania: Aria of Sorrow" on the Game Boy Advance emulator. I've tried several roms and always after 1 minute or less the game stalls, usually during the intro video. I've played other games in the same emulator, the BIOS is the right one, everything seems to work fine but a couple of games with the same behavior. Any other problems with any other emulator as long as I've tried. Any ideas? I'm using a rpi3 and version 4.0.0 beta2 + Logitech 310 gamepad. Cheers


  • Global moderator
    Team

    Hello sorry for my english. check your bios file into recalbox-manager : https://github.com/recalbox/recalbox-os/wiki/recalbox-manager-WEB-interface-(FR) it's ok. try another core with your game. select your game button select metadata try emulator : libretro core gba : gpsp - mgba - meteor choose one exemple libretro snes Visionner l'image clic save, and try again your game



  • Thank you very much. That seems to work fine. The web interface is quite nice, I would suggest to add a button to reboot the OS through the web interface, it is useful when games stalled, much easier than use ssh, log in (specially if you are not sure of the IP) and type the reboot command, or at least suitable for lazy people like me 😉



  • Hi Isidro, I am having the exact same problem as you do, I am also using the same version of recalbox and trying to play Castlevania Aria of Sorrow. Which emulator + core gba did you use at the end that help fix the issue? I can play the game with the "meteor" core but the audio is really crappy.



  • Hello ! If you select the emulator "Liberto" and the core "GPSP" all will work perfectly !



  • Same problem with Harmony of dissonance, I hope this issue can be solved in Recalbox 4.1 because two months ago I was a RetroPie user and I had not that issue with those games under mgba, greetings from México.



Want to support us ?

230
Online

79.1k
Users

20.4k
Topics

149.3k
Posts