Trouble adding roms



  • Hi Guys, I have full rom sets that I am trying to copy across, the Rpi2 loads fine at first using the noobs recalbox installer, everything works fine, I shut down the rpi2 take the micro sd card and use an adaptor to put the roms into the rom folder, and when I put it back in the rpi2 and turn it on, the recalbox splash screen comes up, but then nothing, just black. Is this caused by me putting too many roms on?



  • Hi ive never done it the way youve done it try doing it with windows When the rpi2 and your windows pc is in the same network (lan/wlan doesnt matter) you can put the roms on the pi over the network. the pi will show up as "Recalbox" in that networktab in windows. When you open it all the rom folders are shown ("N64, Snes, PSX" etc) After inserting all the roms restart the pi and test it. It should work. Also check if the roms are okay --> test them first in windows greetings





  • I have tried the same using Windows 8.1 and it doesn't recognise the partition as FAT32 so I've not been able to transfer ROMs this way. The way I've transferred files is via my network and by accessing the shared RECALBOX folders. Are you getting a blank screen after the NOOBs (press 'shift') screen or after the RecalBox splash screen?



  • Hi guys, It was after the noobs screen, I think it may be power related, I have the rainbow square in the top right, but I did some research and some people said it was possibly due to the amount of systems, so I deleted the folders for all the systems I wasnt using, so I just have PSX, SNES, Mega Drive, SEGA CD, N64, the all work except for the N64, it has sound but no video, weird.



  • Have you tried to comment out/remove 'hdmi_drive=2' line in config.txt? I done this by pressing shift at the NOOBs screen and then editing the config from there. This allows me to use Recalbox on my PC monitors via a HDMI > VDI cable. In regards to the rainbow square in the top right corner I get a red/orange square occasionally at start up which means it's getting a little warm, however, I get this when booting from cold. It's a different colour if it's lack of power. I've managed to use a 750ma power supply with my Raspberry Pi 2 but the experience I had was stuttering/hanging occasionally and this is when I saw the rainbox square appear during use.



  • Hi! maybe bit outdated but... i also had problems with the "standard" copy method via smb. To slow and unstable (maybe because of my router? Don´t know yet ...). My solution for copying big, full Rom Collections to the recalbox QUICK is the following: 1. Copy your roms to a blank USB-stick (Fat32) 2. Plug your stick to your pi 3. Connect to your pi via putty ......... lots of tutorials on the web, maybe  https://github.com/digitalLumberjack/recalbox-os/wiki/Root-access-on-terminal-(EN)   4. Then you are ready to copy the roms directly from the stick to a rom folder on your sd card/Recalbox system: On the Terminal (putty) type "mount" for the list of mounted devices. At the end you will find a line like this: "/dev/sda1 on /media/usb0 type vfat .... etc etc". In this case "/media/usb0 is the adress of your usb-stick. ------- look here for help: https://github.com/digitalLumberjack/recalbox-os/wiki/Auto-mount-of-usb-in-place-of-share-partition-(EN) ----------- Now you copy all files from the stick to your sd-card with the CP (copy) command: cp [OPTIONS] SOURCE TARGET For example (copying all files to the roms/snes folder) it would be: cp -rv /media/usb0/* /recalbox/share/roms/snes   Thats it. Copying a full collection of 10 GB took about 15-20 minutes on my pi. Sorry for my bad english, but I hope this helps someone! bye jan


Log in to reply
 

Want to support us ?

288
Online

81.4k
Users

22.2k
Topics

161.3k
Posts