How to return to main menu from MAME games



  • Hi Guys,

    I'm using a Raspberry Pi1, recalbox 7.1.1 (installed today), installed via etcher.

    First of all, what a great bit of kit Recalbox is, a breathe of fresh air. I spent 2 days trying to get MAME roms working on retropie and kept hitting a brick wall. I installed, setup and copied games over to Recalbox in about an hour and i am playing MAME games, amazing!

    If i may i have a few questions:

    • Once in the game how do i return back to the MAME or home screen, exit the game essentially. If i load the game press tab on the keyboard i get the input (general) option and i set UI cancel to the select button and left shoulder, but when i try this nothing happens? If i press select and start together to just goes to a black screen and i have to reboot the Pi. Not sure what i am missing.

    • I'm guessing my games are running slow/laggy due to my Pi1, this is just an experiment as i want to build an arcade cabinet but first i need to know i can get MAME work correctly, i will buy a Pi3 or 4 if this is a success and move to the build project. Is there any known issues with the Pi4 as its new?

    • I'm also guessing that the arcade stick/buttons are mapped in the exact same way as a controller is? Is there any recommendations for sticks i was going to start with a set of EG STARTS from Amazon and then if the project goes well maybe move to a Sanwa set later?

    Any help advice is greatly appreciated, i did google this but couldn't find an answer specific to my request so apologies if i am duplicating work here, I'm new to the emulator scene but loving it so far thanks to Recalbox.

    Thank you
    Disco



  • Ok so i am a little further forward after more testing and reading. I can now boot back to the main menu after changing the USB controller for a PS classic usb controller and reconfiguring the buttons.

    However it doesn't always boot back and I get the black screen, sometimes if i leave it for 10mins it goes back to the main menu other times it just sits there and i have to hard reset.

    I have noticed that if i can boot back to the main menu it wont let me load another rom it just goes to a black screen and sits there (again even waiting 10mins) so i have to hard reset at this point.

    If i then reboot and load the rom that wouldn't load it works! So i basically have to reboot after every time i want to change a game?

    At first i thought it could be because it was MAME roms, but i have since tried SNES and Megadrive and its the same result?

    The hotkey is programmed as left 2 shoulder on the PS classic controller so L2 + start is supposed to boot back right? Which it does about 60% of the time.

    I don't think i am doing anything wrong as it repeated on 3 different emulators now with the same result. I can load and play the first game, but if i want to exit and change the game it only works 60% of the time and when it does it never starts the next rom?

    Any ideas?

    Thanks
    Disco


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @disco78 I'll try to help you quickly:

    Rpi1 is weak hardware, you can't expect great performance, it can't even run all emulators:
    https://recalbox.gitbook.io/documentation/hardware-compatibility/emulators-compatibility

    About MAME: You need to check your ROMSET, it needs to be the same as the one requested by the core (The MAME 2000 core will only perform well with ROMSET MAME 2000 ROMs, you will probably be able to run many ROMS MAME 2003, but they may not have the desired performance).

    About Rpi4: it is a novelty, but it runs most games very well, as far as I know (I don't have an RPi4) the only problems reported are in the N64 and some Dreamcast games.

    It is recommended that you set the Hotkey to Select.

    You shouldn't have any problems with the SNES and Megadrive ROMs, the Rpi1 Hardware is enough.

    Avoid using custom themes on Rpi1, and avoid using many types of consoles on Rpi1 (more than 20 for example - I don't know when it starts to overload), Rpi1 is very weak.

    Did you build your Recalbox yourself, or download a ready-made image from the internet?

    There is no need to restart Recalbox to change the game, you did something wrong manipulation, or is overloading your Rpi1 somehow.

    If possible, flash Recalbox on a Pendrive and test on a computer, so you can test whether the problem is the system or the hardware (although it does not rule out a configuration problem or a problem with defective ROMs, for example).



  • @Zing Thank you very much for taking the time to reply to me.

    So I think my first post was a bit all over the place as there was so many things that worked compared to Retropie but a few little things that didn't, but I was so close and frustrated with myself.

    So for MAME I have just used individual roms as I didn't want 2000+ games. On a fresh boot up of Recalbox the roms loaded every time but when i exited a game with Hotkey + start about 50% of the time the game would go back to the MAME roms selection screen but i couldn't load another game successfully, if i rebooted and tried the next game it would work, i did this about 30 times to try the roms i wanted, same issue.

    I have no themes, overlays or anything else running, i just wanted the basic build to test so i can get going with the arcade cabinet.

    Did i build my own recalbox? If you mean did i download the Recalbox.img and use Etcher to burn it to the SD card and go through the initial boot and setup the controller myself etc then yes i did build my own. FYI Pi1 image.

    I then tried SNES and Megadrive games and it was the exact same problem with them, so at this point i thought the Pi1 can handle the SNES games but i get the same issue, so i thought it might be an issue with the Pi1 and Recalbox?

    I did build a PC x86 and X64 usb stick but I cannot get my PC to go to the bios, even though it says F2 on boot up. So i tried it on my laptop and it says the "selected boot image did not authenticate". So i tried it on my work laptop and it worked, although i can't test with that device as it will cause bit locker to kick in!

    • So now, i have put it on hold as it could be the Pi1 overheating (probably not, but maybe).

    • I can't see that i am missing something with the SNES or megadrive option as that is just the case of build the Recalbox OS, configure controller and copy roms to the right folder, the roms load individually i just have to reboot to load another one, i cannot play a game exit it and start another one without a reboot.

    • I have now ordered myself a Pi3+ and official Pi charger so this will remove the performance issue. I am going to try again from scratch with a fresh build starting with Snes and Megadrive roms, then move to MAME. I will also change the PS Classic controller to have Select as the Hotkey as you have advised.

    Again thank you for taking the time to come back to me with the detailed explanation and advice, i am going to follow this and report back if that is ok with you.

    Thank you for your time
    Disco


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @disco78 About MAME, remember what I warned: ROMs must be the same ROMSET as the core.

    When I ask if you created your Recalbox yourself, I refer to the fact that you downloaded the last official image, clean, without modifications, and personalized it the way you want it. Some people download ready-made images from the internet and it is impossible to find out what has been modified.

    NES, SNES, Megadrive, Mastersystem, Atari, etc., these simpler and older consoles work even on Rpi0, so it's a good reference when you want to test if the problem is the Hardware.

    On computers, you sometimes need to modify some things in the BIOS: Legacy / UEFI, Safe Mode, etc.

    Remember the documentation (the Recalbox team is mostly French, so there is more content in French, and it is the first place to have content):
    https://recalbox.gitbook.io/documentation/v/francais/

    And the tutorials on the official youtube channel (enable subtitles):
    https://www.youtube.com/playlist?list=PL2oNQ0AT7fx2ExiSNrfHUzga5GnogI4sh



Want to support us ?

234
Online

81.9k
Users

22.5k
Topics

162.8k
Posts