Hifi-Berry / mount root



  • Hello

    How can I change the settings required for Hifi-berry (https://recalbox.gitbook.io/documentation/tutorials/audio/hifiberry-audio)??

    Then you have to select the default sound card : just edit /etc/asound.conf (create the file if not already present) with the following content 
    

    I assume the asound.conf need to be create under (root):/etc .. However, I'm unable to create a new file with ssh and I can't mount the root partition for the rpi3 image.

    I also get a lot of kernel errors and gparted

    [57399.194362] debugfs: Directory 'mmcblk0' with parent 'block' already present!
    [57399.548245] mmc0: cannot verify signal voltage switch
    [57399.706129] blk_update_request: I/O error, dev mmcblk0, sector 2080 op 0x0:(READ) flags 0x80700 phys_seg 1 prio class 0
    [57399.962009] mmc0: cannot verify signal voltage switch
    [57400.121017] blk_update_request: I/O error, dev mmcblk0, sector 6306048 op 0x0:(READ) flags 0x80700 phys_seg 1 prio class 0
    [57400.288266] mmc0: cannot verify signal voltage switch
    [57400.449597] blk_update_request: I/O error, dev mmcblk0, sector 2080 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 0
    [57400.449602] Buffer I/O error on dev mmcblk0p1, logical block 4, async page read
    [57400.618024] mmc0: cannot verify signal voltage switch
    [57400.777688] blk_update_request: I/O error, dev mmcblk0, sector 6306048 op 0x0:(READ) flags 0x0 phys_seg 8 prio class 0
    [57400.777691] Buffer I/O error on dev mmcblk0p2, logical block 256, async page read
    [57400.777692] Buffer I/O error on dev mmcblk0p2, logical block 257, async page read
    [57400.777693] Buffer I/O error on dev mmcblk0p2, logical block 258, async page read
    [57400.777694] Buffer I/O error on dev mmcblk0p2, logical block 259, async page read
    [57400.777695] Buffer I/O error on dev mmcblk0p2, logical block 260, async page read
    [57400.777696] Buffer I/O error on dev mmcblk0p2, logical block 261, async page read
    [57400.777696] Buffer I/O error on dev mmcblk0p2, logical block 262, async page read
    [57400.777697] Buffer I/O error on dev mmcblk0p2, logical block 263, async page read
    [57400.971971] blk_update_request: I/O error, dev mmcblk0, sector 28606984 op 0x0:(READ) flags 0x80700 phys_seg 63 prio class 0
    [57430.170885] mmc0: cannot verify signal voltage switch
    [57430.241479] blk_update_request: I/O error, dev mmcblk0, sector 28606984 op 0x0:(READ) flags 0x80700 phys_seg 63 prio class 0
    [57430.600925] mmc0: cannot verify signal voltage switch
    [57430.670092] blk_update_request: I/O error, dev mmcblk0, sector 29655064 op 0x0:(READ) flags 0x0 phys_seg 30 prio class 0
    
    Error reading fat number 0
    plain_io: Input/output error
    Error reading fat number 1
    Could not read first FAT sector
    Cannot initialize '::'
    mlabel: Cannot initialize drive
    
    plain_io: Input/output error
    Error reading fat number 0
    plain_io: Input/output error
    Error reading fat number 1
    Could not read first FAT sector
    Cannot initialize '::'
    
    
    Unable to detect file system! Possible reasons are:
    - The file system is damaged
    - The file system is unknown to GParted
    - There is no file system available (unformatted)
    - The device entry /dev/mmcblk0p2 is missing
    

  • Global moderator Translator
    Translation Master
    Tester
    Global moderator



  • @Zing Thanks for your reply. I could create the file but the sound is going through HDMI nevertheless.
    It doesn't seem to work with my dac light


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @Cheib I don't have this hardware and I can't test it, you need to do more tests, you need to check the entire configuration:

    • Did you edit the /boot/config.txt file as requested?
    • Are all the information in the /etc/asound.conf file correct?
    • Did you edit the information in Alsamixer/Amixer correctly?

    Make sure there are no typos, no unnecessary space (which is what usually happens).



  • @Zing said in Hifi-Berry / mount root:

    Did you edit the information in Alsamixer/Amixer correctly?

    Thanks again for your reply. I'm pretty sure I made correct modification in /boot/config.txt and /etc/asound.conf..

    The issue probably lies much deeper..kernel/dmesg doesn't use the overlay for hifiberry (dtoverlay=hifiberry-dac). I don't think it gets loaded at all at boot.

    There is another thread on this forum but no solution. Guess I'll have to stick with libreelec...



  • @Cheib : Great success:
    I used the dtbo from an old rpi firmware (firmware-1.20181112.zip) with this md5sum:

    9621a8827d53ea92e8d16e5795dd2f9a
    

    moved the entry in /boot/config.txt (dtoverlay) before the include recalbox-config.txt and the gpu_mem entries

    now I can see the hifiberry card in sound settings. 🙂


Log in to reply
 

Want to support us ?

254
Online

81.3k
Users

22.2k
Topics

161.1k
Posts