jeux ne se lancent plus depuis 7.0+



  • Bonjour,

    depuis la version 7 plus aucun jeu ne se lance, je me suis dit que s'était un bug passager et en dépit des nouvelles maj de recalbox le souci persiste.
    J'ai formaté et réinstallé la carte mémoire avec la dernière version à chaque maj de recalbox, et rien ne s'arrange.

    dès que je mets la clé usb comme source pour les roms, aucune rom ne se lance avec un message d'erreur disant bios, rom manquant... alors que j'utilise cette clé usb depuis toujours.

    après un xième formatage comme je l'ai fait ce matin avec la dernière 7.1.1, les roms comprises avec le build comme donkey cong classic snes, marchent donc j'imagine que tout le hardware marche correctement.
    je mets la clé usb en source, et tous mes paramètres sont bien appliqués, ça reboot, mais aucun jeu ne se lance.

    je ne sais pas quoi faire, pouvez vous m'aider à remettre ça en ordre svp ?

    Raspberry Pi model: 3b
    Recalbox version (build) : dernier en date 7.1.1, souci depuis la 7.0
    Matériels (Micro SD, Power Supply, etc.): kit the pi hut (ThePiHut 16GB Raspberry Pi 3 Starter/Media Centre Kit)
    Manette(s): xbox 360
    Thème utilisé : ? je n'ai pas touché à ça.


  • Global moderator
    Global moderator
    Tester

    @Blooky Hello,
    Quelle est la marque et la capacité de ta clé ?
    Quelle sortie choisies tu pour sélectionner ta clé (anyexternal, le nom de ta clé) ?
    Comment as tu formatté ta clé (fat32, exfat, ntfs) ?


  • Staff
    Global moderator
    Team

    Bonjour @Blooky
    dans 99% des cas, le problème est ta clé ou sur ta clé, pas le système.

    Applique les informations données dans ce tuto : https://www.youtube.com/watch?v=skeULeTu7p8&list=PL2oNQ0AT7fx2ExiSNrfHUzga5GnogI4sh&index=23



  • @Scavy c'est une sandisk cruzer fit 32gb (https://www.amazon.fr/SanDisk-Cruzer-SDCZ33-032G-B35-Flash-Drive/dp/B00812F7O8)

    en fait tout a marché parfaitement jusqu'en août dernier pendant les vacances sous recalbox 6.x, c'est depuis la maj en 7.x que c'est fichu.

    j'ai toujours utilisé la sortie vers le nom de la clé USB, (no_name).
    j'ai essayé "any external" encore ce matin, pas mieux.
    j'ai essayé un autre port usb, pas mieux.

    le plus fourbe c'est que tous les paramètres de configuration se chargent bien immédiatement dès que je choisis la clé usb en"no name" ou en "any external", mais aucun jeu ne veut se lancer.

    la clé est formatée en fat32.



  • @acris j'ai deux autres exemplaires de cette clé usb pour des usages n'ayant rien à voir avec recalbox, eux aussi exclusifs, avec lesquelles je n'ai jamais eu aucun souci.

    j'ai déjà regardé cette vidéo.

    je vais essayer avec une autre clé usb.



  • je vais essayer de faire la manipulation à 2m10 dans la vidéo.


  • Global moderator
    Global moderator
    Tester

    @Blooky said in jeux ne se lancent plus depuis 7.0+:

    la clé est formatée en fat32.

    Alors on reprend la clé,
    tu sauvegardes tes répertoires bios, roms, thème, saves sur ton PC,
    on la formatte en exfat en lui donnant un pti nom (genre JeuxRCB),
    on charge sa recalbox sans la clé, on lance Recalbox, on le met sur internal,
    on éteint RCB, on branche sa clé, on relance RCB,
    on va choisir le support "lenomdemaclé" (JeuxRCB par exemple),
    on fait un reboot, quand c'est loadé, on vérifie qu'on est sur la clé (dans système, la taille de ton share),
    on ré-éteint tout proprement, on met sa clé sur le PC et on recopie uniquement bios, saves, roms et ton thème éventuellement. On ne recopie pas les vieux fichiers systèmes !
    Et ça va marcher 🙂



  • ce n'est pas la même machine, mais pour info j'ai aussi un Gpi case...
    ... et je viens de m'occuper de la réinstallation complète en 7.1.1 et tout a marché immédiatement.
    j'avais oublié que l'accès aux roms se faisait directement dans l'explorer via le wifi ! c'est vraiment pratique.
    bref je vais m'occuper de mon rpi 3b aussi.



  • mon premier essai c'est avéré infructueux.
    au moment du reboot "on fait un reboot, quand c'est loadé, on vérifie qu'on est sur la clé (dans système, la taille de ton share),"
    la tv affiche n'importe quoi et je ne peux rien faire à part éteindre en débranchant le rpi
    c'est vraiment curieux.
    je vais essayer avec une autre clé usb, formatée en exFAT etc comme préconisé.


  • Global moderator
    Global moderator
    Tester

    @Blooky said in jeux ne se lancent plus depuis 7.0+:

    j'avais oublié que l'accès aux roms se faisait directement dans l'explorer via le wifi ! c'est vraiment pratique.

    Sur le Pi0, tu peux aussi mettre ta carte directement sur le PC et accéder au share. S'il n'apparait pas, c'est qu'il faut lui attribuer une lettre (c'est pas toujours automatique et c'est indépendant de RCB). Dans ce cas, utilise le gestionnaire de disques de win10 ou un soft style minitool partition wizard, attribue une lettre et le share apparait.


  • Global moderator
    Global moderator
    Tester

    @Blooky said in jeux ne se lancent plus depuis 7.0+:

    mon premier essai c'est avéré infructueux.
    au moment du reboot "on fait un reboot, quand c'est loadé, on vérifie qu'on est sur la clé (dans système, la taille de ton share),"
    la tv affiche n'importe quoi et je ne peux rien faire à part éteindre en débranchant le rpi
    c'est vraiment curieux.
    je vais essayer avec une autre clé usb, formatée en exFAT etc comme préconisé.

    Mauvais flash, mauvaise carte SD ? C'est quoi la marque et modèle ?
    On conseille les sandisks classe 10.



  • @Scavy j'ai fait mon premier essai avec la même clé usb, en suivant la procédure (formater en exfat 32ko), je vais essayer avec une autre clé usb (cette fois volontairement bas de gamme) pour voir.

    tout va bien du côté des cartes mémoires micro sd HC, jamais une panne, bon après c'est pas comme si je les utilisais tous les jours à fond...
    j'en utilise plusieurs, des sandisk ultra 32gb class 10.
    rien qu'en ouvrant un de mes tiroirs, je viens d'en trouver une qui n'est pas utilisée d'ailleurs.

    par ailleurs, je viens de retomber sur le rpi 400, ça m'a l'air fort sympathique cette histoire de pi4 intégré au clavier !


  • Global moderator
    Global moderator
    Tester

    @Blooky d'accord c'est l'install sur la clé qui ne fonctionne pas, pas l'installation sur ta carte SD.
    Lance ta RCB avec la carte SD, plug ta clé formattée préalablement en exfat, va dans système choisis le nom ta clé comme support externe, reboot et laisse l'architecture se faire.
    Perso pour être certain de savoir qu'est ce qui a booté lors de mes tests, je laisse la carte SD en langue et clavier UK et je mets mon support externe en langue et clavier FR. Je sais direct ou je suis 😉
    Pour les cartes, meme les sandisk se corrompent ! J'en ai déjà abattue une paire lors des tests ! 🤕 🤒 😂



  • je viens de commander une nouvelle clé usb sandisk ultra fit 32gb.
    je reprendrai la manipulation avec cette nouvelle clé, comme ça plus de doute avec celle qui déconne actuellement.



  • @Scavy said in jeux ne se lancent plus depuis 7.0+:

    @Blooky said in jeux ne se lancent plus depuis 7.0+:

    la clé est formatée en fat32.

    Alors on reprend la clé,
    tu sauvegardes tes répertoires bios, roms, thème, saves sur ton PC,
    on la formatte en exfat en lui donnant un pti nom (genre JeuxRCB),
    on charge sa recalbox sans la clé, on lance Recalbox, on le met sur internal,
    on éteint RCB, on branche sa clé, on relance RCB,
    on va choisir le support "lenomdemaclé" (JeuxRCB par exemple),
    on fait un reboot, quand c'est loadé, on vérifie qu'on est sur la clé (dans système, la taille de ton share),
    on ré-éteint tout proprement, on met sa clé sur le PC et on recopie uniquement bios, saves, roms et ton thème éventuellement. On ne recopie pas les vieux fichiers systèmes !
    Et ça va marcher 🙂

    Bonjour,
    Je viens de m'en occuper avec une nouvelle clé usb, toujours une Sandisk ultra de 32go certes, et je confirme que tout a bien fonctionné du premier coup, je récupère donc enfin une recalbox fonctionnelle pour mon salon.
    Merci !

    J'en profite en passant pour dire que j'ai un peu joué sur mon GPi Case entre noël et nouvel an et que tout a bien fonctionné aussi.


Log in to reply
 

Want to support us ?

344
Online

81.3k
Users

22.2k
Topics

161.1k
Posts