Aucune connexion réseau ... sans clé de connexion



  • Bjr,

    Nouvelle installation sur PI3B+ ...

    Aucune connexion réseau,
    (le dhcp est en 192.168.0.x )

    ni en filaire, l'adresse reste bloquée en 169.254.1.3
    ni en wifi qui détecte bien les réseaux wifi alentour ... mais aucune connexion

    Nota : aucun mot de passe pour se connecter au wifis

    j'ai creusé les forums tte la journée ... je ne vois pas.

    Si qqu'un à du temps à me consacrer, 1000 mercis d'avance
    🙂

    p


  • Staff
    Global moderator
    Team

    bonjour
    as tu redémarré ton modem ?



  • @acris
    ??
    Pourquoi redémarrer son modem?



  • This post is deleted!


  • @pierrem

    Votre box n' est elle pas active pour le filtrage d' adresse MAC ce qui rendrait impossible la connexion d' un nouvelle appareil sur la box ?.


  • Staff
    Global moderator
    Team

    @pierrem
    pourquoi pas de clé de connexion wifi ?



  • Merci à tous...

    -aucun filtrage sur la box
    -pas de clef car le voisin le +proche est à 2km

    Fyi: sur le réseau sont connectés du W10, des rpi divers modèles, des esp8266 et esp32... Et tout ce petit monde communique bien.

    Juste ce "dernier" rpi3 recallbox qui ne veut rien savoir... pour l'instant.

    J'ai essayé une ip fixe : même problème...

    Dans recalbox.conf, le country est bien á FR, le réseau WiFi est bien détecté
    Mais pas de connexion.

    J'ai essayé en. V6. 1.1 et la v7 dispo au téléchargement, même problème

    Le rpi3 utilisé tournait bien avec octoprint, donc peu probable que souci hardware

    Suis preneur d'idées !

    Merci d'avance
    P



  • Re- ...

    Bon, je ne sais pas comment/pourquoi ... mais ça progresse.

    La connexion filaire est OK, je peux accéder à l'interface web.

    Le wifi ne fonctionne toujours pas, je soupçonne un problème de clef vide.
    Si quelqu'un à une idée/suggestion sur ce point précis (a priori et d'après le forum, il est possible d'avoir une clef vide ... mais la solution n'est pas indiquée)

    Aussi, depuis l'interface web, si je saisis le 'bon' SSID ... il ne semble pas enregistré : après reboot, c'est un identifiant quelconque qui est affiché dans le champ de saisie (et avec un mot de passe, alors qu'il est censé être vide).

    Question supplémentaire : comment fixer l'adresse filaire ?
    Pour l'instant elle est attribuée par le dhcp mais ça ne m'arrange pas.

    Encore merci à tous de vos conseils
    p


  • Staff
    Global moderator
    Team

    @pierrem
    essaie d'entrer ton SSID dans recalbox.conf directement.
    J'ai remonté la question aux developpeurs mais vue que tu n'es pas sécurisé , y a très peu de personne dans ce cas, l information ne parvient seulement maintenant.



  • @acris

    Effectivement ...
    1°)
    -connexion filaire

    • interface web
    • modif dans le recalbox.conf
    • enregistrement
    • reboot
      2°)
      connexion filaire OK
      debranchement du câble réseau
      activation wifi

    miracle !
    Connecté en WiFi (ipV6 ...)

    merci du conseil.

    Je vais tâcher de fixer l'IP ... en V4
    🙂



  • @acris

    En fait, la connexion WiFi est établie une fois sur deux ou trois ...
    Et impossible d'attribuer une IP fixe dans recalbox.conf
    Cas connexion filaire : la modif n'est pas sauvegardée (malgré le message contraire)
    Cas connexion WiFi : message erreur -> config non enregistrée

    Désolé ....
    🙂

    p



  • @pierrem
    Quelle est l’IP du rpi?
    Et les paramètres de ta carte réseau ?
    IP de ton routeur ?



  • @Eptdqcn41700

    routeur : 192.168.0.1
    IP du rpi3 (en DHCP) : 192.168.0.3

    paramètres carte réseau : default recalbox



  • @pierrem

    paramètres carte réseau : default recalbox

    Je ne comprends pas trop..
    Tu veux accéder a ton rpi avec un pc?
    Quand je demande les paramètres de la carte réseau, c’est pour savoir si la plage d’adresses est bonne..
    Il manque pas mal d’infos sur ta config et ton réseau ( si tu peux faire un schéma par ex. )
    A moins que je ne fasse fausse route !



  • @Eptdqcn41700

    Maintenant, j'accède bien au rpi sur lequel il y a recalbox ... mais uniquement en filaire.
    Pas de problème d'adresse ni de DHCP, presque tout baigne
    🙂

    Restent 2 problèmes :

    • se connecter au WiFi sans clef (plusieurs AP essayés, ça ne veut pas)
    • définir (pour le Wifi) une IP fixe, quand j'aurai réussi à me connecter

    J'envisage de mettre une clef sur l'un des AP ... mais ça implique de reconfigurer une partie des esp, ce qui me fatigue rien que d'y penser
    🙂

    Je suis preneur d'idées ...
    Il doit bien avoir moyen de se connecter avec un password wifi vide ...
    j'ai essayé (dans recalbox.conf) de ne rien mettre, de mettre 2", de mettre empty ... nada

    FYI, si le Wifi est activé (et donc non connecté ...), le filaire passe automatiquement en IPV6.

    Merci de ton aide !



  • Hello,

    Montage d'un AP wifi avec mot de passe ... recalbox se connecte parfaitement.

    Il ne semble donc pas possible de se connecter en wifi sans mot de passe (clef).
    Pour moi c'est un bug
    🙂

    Merci à tous


  • Staff
    Global moderator
    Team

    Bonjour
    tu es un cas isolé, et effectivement c'set sûrement un bug car le wifi a été modifié, réécrit.
    Un réseau doit être protégé même si tu es une maison isolée.

    Pour le moment, la team dev est concentré sur autres choses de plus important
    bump buildroot, kernel sur les différentes plateformes, et ce correctif n'est pas leur priorité pour le moment.
    Je t'encourage à ouvrir une issue ici https://gitlab.com/groups/recalbox/-/issues
    et d expliquer tes tests afin que ce soit pris en charge



  • @acris

    Okee dokee
    j'ouvre une issue asap

    Et je confirme que je/ça doit être un cas isolé
    🙂

    Encore merci à tous


Log in to reply
 

Want to support us ?

262
Online

81.3k
Users

22.2k
Topics

161.1k
Posts