Bug dans la gestion du caractère '&' dans la clé wifi



  • Bonjour,

    Je voudrais signaler un bug que je rencontre depuis quelques semaines/mois. Alors malheureusement je ne saurais pas dire précisément depuis quelle version, ni quand ce problème ce produit, mais il se trouve que régulièrement (et ça vient de me le faire là à l'instant en mettant à jour ma recalbox en version 7.1.1-reloaded), lorsque je la démarre, ma recalbox se retrouve déconnectée du réseau, tout simplement parce que la clé wifi n'est plus bonne.

    Et effet, lorsque je vais dans le menu pour vérifier la clé wifi, il se trouve que chaque caractère '&' présent à plusieurs reprises dans ma clé wifi est transformé par la chaîne ";wifi.key=new key" à la manière d'un simple string replace.
    (ex: si ma clé wifi est "AA&11&ZZ", elle est remplacée par "AA;wifi.key=new key11;wifi.key=new keyZZ")

    Et donc je dois régulièrement refaire une passe dessus pour rétablir les '&', ce qui n'est pas des plus pratique avec une manette 🙂

    Est-ce un bug de recalbox ? Est-ce qu'il y a quelqu'un qui a ce caractère dans sa clé et qui n'a jamais rencontré ce problème ?


  • Staff
    Global moderator
    Team

    Bonjour @DuxBellorum
    quelle idée de mettre des caractères spéciaux 😉
    j'ai remonté l'information.

    as tu essayé d'entrer la clé wifi directement dans recalbox.conf
    en mettant le \ comme indiqué pour les caractères spéciaux.

    ## Wifi KEY (string)
    ## after rebooting the recalbox, the "new key" is replace by a hidden value "enc:xxxxx"
    ## you can edit the "enc:xxxxx" value to replace by a clear value, it will be updated again at the following reboot
    ## Escape your special chars (# ; $) with a backslash : $ => \$
    wifi.key=AA\&11\&ZZ
    

    sous quelle bord ? pc ? rpi ? odroid ?



  • Bonjour @acris,

    Merci pour ta réponse !
    Effectivement, quelle idée de vouloir renforcer les mots de passe par défaut 😉

    Jusqu'ici j'ai toujours saisi la clé via l'interface dans ES (puisque le recalbox.conf je l'édite via l'interface web, et quand la conf réseau saute ben j'ai plus accès à cette interface).
    Donc je suis allé voir le recalbox.conf, et j'ai vu que la clé était présente en clair, sans échappement pour les caractères spéciaux "wifi.key=AA&11&ZZ".
    J'ai échappé tous mes caractères spéciaux (j'en ai un paquet, mais à priori aucun ne m'a "échappé" 😉 ), j'ai reboot, et là le champ wifi.key contenait de nouveau la clé wifi en clair (donc pas du tout le "enc:xxxxxx" promis dans le commentaire au dessus), et les '\' d'échappement avaient disparu, donc c'était de nouveau "wifi.key=AA&11&ZZ" comme avant. Donc même si ça fonctionne, j'imagine que ça n'est pas normal ?

    J'ai tenté 2-3 reboot consécutifs, la clé n'a pas bougé, mais comme je ne sais pas exactement quel évènement déclenche le bug pas sûr que ce soit un état stable.

    Je suis sur un RPI3b+.



  • PS: juste pour préciser que ma clé contient plein de caractères spéciaux différents, que le même caractère spécial peut être présent à de multiples reprises, et c'est bien uniquement le '&' - et toutes les instances de '&' - qui posent problème, pas de souci avec les autres.


  • Staff
    Global moderator
    Team

    @DuxBellorum
    le mot de passe n'est plus crypté, le texte n'est pas à jour.



  • Par contre, le mot de passe wifi de mon côté n'a pas de caractère échappé, tous les caractères sont lisibles normalement et tout passe. Je pense que l'échappement de certains caractères spéciaux n'est plus nécessaire (j'ai un # dans mon code qui n'est pas échappé et il fonctionne) 🙂


Log in to reply
 

Want to support us ?

381
Online

81.4k
Users

22.3k
Topics

161.4k
Posts