8bitdo NES30 not working with Recalbox 7.0.1 when connected USB cable, worked fine for a few days no not at all



  • 8bitdo NES30 controller using USB cable , NOT BT, with Recalbox fresh load 7.0.1 on pi 4 , was working fine the other day, now suddenly when i plug it in after turning on pi and recalbox it says detected it as new controller 😐 wth, so i fire up a BT gamesir controller enter configure controllers it sees the Gamesir i just powered on and the NES30 , but i'm not able to configure the NES 30.. i can unplug the NES30 , it powers off, then power on the NES30 and it connects BT and works fine ??!! what gives here, i mean it was working fine, i tried a different USB cable, same thing on my pi 3 with recalbox 7.0.1 used to work now does not just out of the blue.

    i'm scratching my head. oh and i have a 2nd 8bitdo NES30 it does the same thing. I also have 2 SNES30's from 8bitdo they work fine still plugged in USB.. some games i avoid BT because let's be honest there is some times slight tiny delays in BT especially when i'm sitting 12 ft away in a larger theater room 🙂 . so i have extra long USB cables, and YES i tried short 6 ft normal USB cable as well still same thing. i even left the controllers plugged in on boot up as well.. i mean these were working perfectly fine the other day. there is no way both of them had their USB ports go bad on the controllers at exactly the same time 😐

    anyone else have issue ? or have an old 8bitdo NES30 laying around you can connect to 7.0.1 recalbox and test for a week and let me know. again this is not making logical sense to me.



Want to support us ?

315
Online

80.5k
Users

21.7k
Topics

158.3k
Posts