7.0.1 - Controller works in EmulationStation but not in RetroArch



  • Hi! Congrats to the team on the release of Recalbox 7!

    I finally decided to try the new version today so I flashed a clean install of 7.0.1, my setup is:

    • Raspberry Pi 3 Model B
    • A pair of 8bitdo NES30 PRO controllers

    I turn on my controllers with just the power button and they work fine on Recalbox 6.1.1

    In 7.0.1 on the other hand, not so fine.

    • I start with a USB keyboard plugged in, I turn the controller on, press the BT button to enter pairing mode (blue light flashes quickly)
    • I choose PAIR A BLUETOOTH CONTROLLER, choose the NES30 PRO, connect it works, I can choose OK and go back using the controller already.
    • I choose CONFIGURE A CONTROLLER and set up all the buttons, I use SELECT for the Hot Key. I make sure the 8bitdo NES30 PRO is selected as INPUT P1
    • I can navigate the GUI with the controller with no issues, the controller reconnects if I restart, power cycle, etc.
    • I start 2048 from the included ROMs (Nintendo Entertainment System) and none of the buttons or Hot Key combinations work. The USB keyboard doesn't work either (Esc, Enter, A, S, etc.)
    • I turn the controller off, I see the popup notification about it have been disconected, turn it back on, it connects, I can play the game but pressing SELECT will cycle through the shaders, SELECT + START will quit Retroarch but not without switching to a new shader first
    • I can also unplug/plug the USB keyboard and it starts working too.
    • I launch another game, the controller doesn't work again. Power cycle the controller, it works, I press SELECT + B, the Retroarch menu shows up but the controller stops working again. Power cycle the controller again, it works but it is almost impossible to set up anything in Retroarch since it seems to be reading each key press multiple times, the selection jumps several lines at the slightest press.

    At this point I have tried several emulators, and power cycling both the pi and the controllers.

    I can't also get the HARD RESET to work with my USB keyboard, I have tried each and both SHIFT keys, after rebooting and power cycling the pi, nothing does the trick.

    So I 'rm -rf' the /share/ folder to start over with the default configurations, and try the other controller, same results. I also tried pairing the controller but NOT running the configuration, leaving INPUT P1 as DEFAULT instead of "8bitdo...", tried other Retroarch cores, etc. Tried both of the controllers in case one was faulty too.

    I also tried using one of the controllers via USB to remove the keyboard from the equation, with the same results.

    Am I missing something? The navigation in EmulationStation works great but Retroarch doesn't take the controller or acts weird when it does.

    Edit: I see a similar issue reported already so I guess it is a matter of waiting now:
    https://gitlab.com/recalbox/recalbox/-/issues/1378
    Thanks for any advice, I would like to be able to use the new version if possible.



  • I had a similar problem with a retrobit sega genesis bluetooth controller using recalbox 6.1.1 and now with 7.0.1



Want to support us ?

257
Online

80.5k
Users

21.6k
Topics

158.2k
Posts