Messed up joystick order (Raspberry Pi 2)



  • Hi! I'm new here, but I'd like to say that I appreciate your work. I'm using a PS3 controller, which works like a charm. The problem occurs when I'm connecting more controllers, such as Wiimote to play miltiplayer. When I'm restarting Recalbox and trying to play with just the PS3 controller - it doesn't connect. The only way to get it to work is by first connect the Wiimote, then the PS3 controller connects instantly. I'm guessing it has to do with the order of the controller. When I had 4 joysticks connected the Wiimotes was labeled from #0 to #2, and the PS3 was #3. If I'm first syncing the PS3 it will get the #0. When I'm adding a Wiimote the PS3 will get #1, and so on.. I've tried both the 3.3 and 4.0, it's the same issue. The only way to get it to work without using the Wiimotes is by doing a complete new installation - which is a pain.. Help appreciated.



  • Hello, question, did you try the new option added in recalbox 4.0.0 "forget bluetooth controllers". You can find it on controllers setting in ES.



  • Yes, I tried that - no reaction. How is that suppose to work, when you restart? I'm starting to think it's the Wiimotes that messes everything up. Even when the PS3 is #0 the same problem appears.



  • Can you please open an issue on github ? https://github.com/recalbox/recalbox-os/issues



  • Yes, done.



Want to support us ?

321
Online

82.0k
Users

22.5k
Topics

162.9k
Posts