GPIO reseting



  • Hello everyone, I would first like to thank the developers that have brought Recalbox to us. What a fantastic frontend. I have used several frontends on very expensive machinery, but this is a testament, that you don't need big fancy expensive equipment to have fun. Thank you so much for this. So, I've been trying to use the GPIO as my keyboard encoder.  Now, to my question. Each time I try to SSH in to my Raspberry Pi 2 and change the controller settings to enable GPIO, even after saving, I can restart my Pi, and the config file would be changed to disable the GPIO keys, even though I have enabled them. Am I overlooking something here? Thanks again guys   # ------------ D3 - GPIO Controllers ------------ # ## GPIO Controllers ## enable controllers on GPIO with mk_arcarde_joystick_rpi (0,1) controllers.gpio.enabled=1 ## mk_gpio arguments, map=1 for one controller, map=1,2 for 2 (map=1,map=1,2) controllers.gpio.args=map=2


  • Team

    Hi, try to quit emulationstation (F4 with a keyboard or killall emulationstation while ssh) before editing and rebooting Just to be sure : you are tring to set only one controller on the GPIO2 port here ? You should use map=1 for 1 controlelr and map=1,2 for 2 controllers.



  • THis was a very weird experience. I tried and tried and tried, but no progress. I decided to down load and reinstall recalbox, and configuration worked totally fine. I must have messed something up in the main Download?? IDK. Thanks again for your help and bringing us this awesome product.


Log in to reply
 

Want to support us ?

Join us on :

191
Online

26879
Users

13855
Topics

105387
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.