DosBox - Dungeons Keeper



  • Hi guys,

    I need your help for using Dungeons Keeper with DosBox (Recalbox Dragonblaze on RP3B+).
    I am a novice about Dos so reading the guide ‘How to use DOSBox to Emulate DOS games‘ didn’t clarify all.
    I have already done an experiment installing The Settlers 2 and it worked well.
    I followed this good tutorial on YouTube
    https://youtu.be/rTYBj_WOnnk
    However the process for installing The Settlers 2 is different than for Dungeons Keeper because in this case there is a Bin/cue file in the folder. I attached the picture with the files I have in my dungkeep.pc
    Can anyone help me with that? I need really basic instructions because many things clear for you are not for me...

    Thank you very much

    folder.png


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator



  • Hi @Zing thank you for your reply. I have already read the link you posted but it’s not completely clear to me.
    I have tried different things but it does not find the cd (I have bin and cue file).

    Imgmount d .\cd\KDDISK~1.cue -t iso





  • I have the same question, thanks for reply


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @Fefo81 Let me better understand the situation (I don't speak English perfectly): the files in the print that you showed in the post, are inside a .bin file, right?
    I don't have this game, nor another game in this format, but, I can recommend:
    1 - Which is probably the easiest: open the .bin file on a computer, and extract all the content, using programs such as daemon tools, or PowerIso, or any program that manipulates .ISO / .bin type CD images and others. After that, just follow the original DOSBOX user manual, which I sent the link to earlier.
    2 - Continue the way you are trying to do: read these links:
    https://www.dosbox.com/wiki/MOUNT#Mounting_a_CD_ROM_drive
    https://www.dosbox.com/wiki/IMGMOUNT

    From what I read in the manuals (I never tried):
    First of all, you need to mount the folder where the .bin file is, and as far as I understand Reccalbox already does this automatically.
    After that, you use the command you tried: "Imgmount" by opening the file as if it were in the main directory from which you just mounted the first command (which by its print, is not being recognized, according to manual, in linux the path is read with "/" instead of "", you can see how in your print the path that Recalbox mounted automatically).
    So, you need to enter the partition you mounted to the file above, in your case d:
    And finally, start the main .exe file.

    But, if your .cue / .bin is actually the game installation, when you do all of that, it will launch the installer, and create a new folder with the game "installed", and, to play, you will have that starts with the game's .exe, not the installation's .cue.



  • @Zing Thank you very much. I’ll try and I let you know.



  • @Zing New update about this endeavour...
    I mounted the game on daemon tools and then I copied and paste the game on the dos folder in recalbox.
    Following the tutorial below that helped me to Previously install The Settlers 2, I added a file DOSBox.bat (inside setup.exe).
    https://youtu.be/rTYBj_WOnnk
    The setup started well. I fixed the audio. Then I clicked install in the game setup menu. The game (Dungeons Keeper) asked me the path giving me this line: c:\keeper
    I completed the line in this way: c:\keeper/keeper.exe
    This command triggered a video confirming installation of the game completed.
    I open the dosbox.bat file and inside I change setup.exe to keeper.exe. However recalbox started loading the game but then it got back the menu.
    So I changed dosbox.bat from keeper.exe to keeper/keeper.exe but the game got back to the menu
    I changed dosbox.bat from keeper/keeper.exe to keeper\keeper.exe
    In this case dosbox Black screen starts loading. It seems like it’s loading something but then it got back to recalbox menu.

    Any help?

    Thanks


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @Fefo81 please make a print of the folder structure at this moment, and a print of the commands you are using, so that I can better understand.



  • also add a line "pause" to the end of your dosbox.bat this will allow you to see the error that's causing the program to die.



  • This is the picture of Dosbox... it said to install the cd... I don’t understand
    C5B8B357-83A8-4FAA-A999-2C060A789AB4.jpeg

    This is the content of the folder dungkeep.pc
    30434140-7E5D-455F-8C1B-5E9EE6CFE736.png

    This is the content of the folder keeper
    C6AABCF3-CCB7-4916-B49B-74A82C854585.png

    Thanks for your help


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @Fefo81 WOW, it looks like you mistook half the information!
    And checking out the prints, you told me one thing, but it's actually another.
    Let's go to the beginning, you have these files in the dungkeep.pc folder: PRINT 1

    I notice that there is a folder "cd", which has the file KDDISK ~ 1.cue (that you unzipped the corresponding .bin), and in fact, I understood that these files in the image above were inside a file. bin:

    @Zing said in DosBox - Dungeons Keeper:

    Let me better understand the situation (I don't speak English perfectly): the files in the print that you showed in the post, are inside a .bin file, right?

    This is not the situation, so the idea is different:
    Let's start from the first print you sent, in fact, it wasn't inside a .bin file, and you didn't need to unzip anything. Go back to that step, the way the game is in the first, and ignore the other steps you did.

    In fact, you need to mount the file. cue that is in the cd folder, and after that, run the keeper.exe file that is in the main folder, you don't need to unzip anything, and you probably won't even need to install anything.
    It looks something like this:

    imgmount d "/recalbox/share/roms/dos/dungkeep.pc/cd/KDDISK~1.cue" -t iso
    C:
    keeper.exe
    


  • @Zing first of all thank you very much for your help and for being so patient. As I said in the first post I’m a novice.
    So If I understood correctly, I deleted the content of the folder extracted with daemon tools and I replaced in the dosbox folder the content I had at the beginning of the process. I also added the dosbox.bat and I wrote the commands you suggested me.
    The game seemed to start but then appeared a screen asking for the cd.
    Have I missed something?
    Thanks


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @Fefo81 Well, I'm helping without being sure (because I never did), but if we insist, at some point it will work!
    If the executable starts, but does not recognize the CD, it indicates that the CD was not mounted correctly, do the following, try only the command:

    imgmount d "/recalbox/share/roms/dos/dungkeep.pc/cd/KDDISK~1.cue" -t iso
    pause
    

    And take a print, it will give an error message in that command, we need to know what it is.
    And, take a print of the contents of the "cd" folder.

    Anticipating the result, check the correct name of the .cue file, I copied the name "KDDISK ~ 1.cue" from one of the prints you posted, but I didn't see what the correct name was. If that name is wrong, already try to put the correct name, in the command I quoted in the previous post and see what happens.

    Everything indicates that either the path is wrong, or the name of the file, and therefore is not mounting the CD, which is necessary to run the game.


  • CRT Hero

    Hi @Fefo81, @gabooks and @Zing

    I tried on my side and it's working with this configuration :

    Below you can see files and directories inside my "Dungeon Keeper.pc" directory

    80a84bc2-21e6-4364-b91a-c04d92c02288-image.png

    Below the content of my "CD" directory

    adcbe145-0c01-46d1-9f0b-36ead2c9bdf6-image.png

    And the content of "KEEPER" directory

    da4e5fd8-5b94-4c1b-b04a-09414852d30f-image.png

    Here is my "dosbox.bat"

    1ff9597f-3c96-4bf4-9c26-6f205348e094-image.png

    You can remove the "pause". I put it here to check if CD image mount correctly

    Hope this can help you



  • @nexusone13 @Zing Thank you very much for your effort.
    I tried this configurations moving my files coping your directories (names are the same). But I noticed I don’t have the file deeper.exe
    Unfortunately didn’t work.
    0E8FB7AC-3B31-4ED1-AF01-5AA5A6E55C33.jpeg

    I noticed I have this file in my folder
    Below the content. Does it make any sense to you?

    C99BB3ED-929F-4916-8151-33DDA5D14A64.png



  • I noticed I have this file in my folder
    Below the content. Does it make any sense to you?

    C99BB3ED-929F-4916-8151-33DDA5D14A64.png


  • CRT Hero

    Deeper is useless, it's an extension of the main game.

    It's your configuration ?

    fd9e835f-5a5c-49d3-9e09-b37d1a36ccdb-image.png

    So could you make a screenshot of the content of the "CD" directory please


  • CRT Hero

    @Fefo81 said in DosBox - Dungeons Keeper:

    I noticed I have this file in my folder
    Below the content. Does it make any sense to you?

    C99BB3ED-929F-4916-8151-33DDA5D14A64.png

    @Fefo81 all this batch file are useless in our case.

    Be careful, if you renamed the CD image (.cue and .bin), you must open the .cue file with a text editor to modify the content corresponding to the .bin name



  • @nexusone13 Exactly. This is my configuration.
    Below the content of the cd folder
    0CB3671A-519E-43EF-A5F3-1EB3B70C4C8F.png



Want to support us ?

297
Online

80.4k
Users

21.5k
Topics

157.3k
Posts