How to disable hciuart on Raspberry Pi 3 B+?

  • Hello to all RecalBox enthusiasts.

    I want to use an external USB Bluetooth dongle for my controller so I'm trying to disable onboard WiFi and Bluetooth on my RPi 3 B+ (I won't be using WiFi, so I want to turn it off too).

    After logging into the terminal as a root (user: root, password: recalboxroot) I typed the following commands:

    1. "mount -o remount, rw /boot" to remount partition on read-write
    2. "nano /boot/config.txt" to edit the file located at /boot/config.txt

    Then I've added to the config.txt file this overlays:

    #Disable onboard WiFi and Bluetooth

    Then closed and saved the file with "CTRL + X", "Y" and "ENTER".

    Now I have to disable hciuart but the command "sudo systemctl disable hciuart" doesn't work at all 😞
    After typing it in, the terminal shows me "-sh: sudo: command not found" 😞

    Is there any other way to disable hciuart?
    Thank you in advance for any tips.

  • Staff
    Global moderator


    no need sudo command, because in recalbox, user is root.

    the correct command line is :

    systemctl disable hciuard

  • @acris Thank you for your quick reply, but after entering the command "systemctl disable hciuart" the terminal responds to me as follows: "-sh: systemctl: command not found".
    I don't know what I'm doing wrong, but this command does not work 😞

  • After some testing, I've realised that there is no need for disabling hci_uart in relalbox 6.1.1 because my USB bluetooth dongle works well on default settings. There is no need for disabling RPi's 3B+ onboard bt module too (by adding dtoverlay=pi3-disable-bt in config. txt).

Log in to reply

Want to support us ?