Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

PS1 DualShock controlle



  • I have the same problem, and a few more details, when trying to get a PS1 DualShock controller working with a USB adapter.

    All (buttons and thumbsticks) work correctly in:
    -recalbox v4.0.0-beta5

    X, O and Square buttons do not register:
    -recalbox 6.1.1 Dragonblaze
    -Retropie xxxx

    ..meaning, the "Configuring" dialogue in the recalbox menu can't be completed because the SNES equivalents, A, B and Y don't register button presses.

    The sdl2-jstest output shows only 14 (0-13) button codes, but there should be 3 more:

    recalbox 6.1.1 output:
    -=============================
    sdl2-jstest -l
    Found 1 joystick(s)

    Joystick Name: 'Sony PLAYSTATION(R)3 Controller'
    Joystick Path: '/dev/input/event1'
    Joystick GUID: 030000004c0500006802000011810000
    Joystick Number: 0
    Number of Axes: 6
    Number of Buttons: 13
    Number of Hats: 0
    Number of Balls: 0
    GameController:
    Name: 'PS3 Controller'
    Mapping: '030000004c0500006802000011810000,PS3 Controller,a:b0,b:b1,back:b8,dpdown:b14,dpleft:b15,dpright:b16,dpup:b13,guide:b10,leftshoulder:b4,leftstick:b11,lefttrigger:a2,leftx:a0,lefty:a1,rightshoulder:b5,rightstick:b12,righttrigger:a5,rightx:a3,righty:a4,start:b9,x:b3,y:b2,'
    Axis code 0: 0
    Axis code 1: 1
    Axis code 2: 2
    Axis code 3: 3
    Axis code 4: 4
    Axis code 5: 5
    Button code 0: 307
    Button code 1: 310
    Button code 2: 311
    Button code 3: 312
    Button code 4: 313
    Button code 5: 314
    Button code 6: 315
    Button code 7: 317
    Button code 8: 318
    Button code 9: 544
    Button code 10: 545
    Button code 11: 546
    Button code 12: 547

    And when I run "sdl2-jstest -t 0", the three mentioned buttons do show any input when pressed but if I press another button like the right trigger, I see this message:

    "INFO: The key you just pressed is not recognized by SDL. To help get this fixed, please report this to the SDL forums/mailing list https://discourse.libsdl.org/ EVDEV KeyCode 313"

    Compare to recalbox v4 output:
    -=============================
    sdl2-jstest -l
    Found 1 joystick(s)

    Joystick Name: 'Sony PLAYSTATION(R)3 Controller'
    Joystick Path: '/dev/input/event0'
    Joystick GUID: 030000004c0500006802000011010000
    Joystick Number: 0
    Number of Axes: 4
    Number of Buttons: 19
    Number of Hats: 0
    Number of Balls: 0
    GameController:
    Name: 'PS3 Controller'
    Mapping: '030000004c0500006802000011010000,PS3 Controller,a:b14,b:b13,back:b0,dpdown:b6,dpleft:b7,dpright:b5,dpup:b4,guide:b16,leftshoulder:b10,leftstick:b1,lefttrigger:b8,leftx:a0,lefty:a1,rightshoulder:b11,rightstick:b2,righttrigger:b9,rightx:a2,righty:a3,start:b3,x:b15,y:b12,'
    Axis code 0: 0
    Axis code 1: 1
    Axis code 2: 2
    Axis code 3: 5
    Button code 0: 288
    Button code 1: 289
    Button code 2: 290
    Button code 3: 291
    Button code 4: 292
    Button code 5: 293
    Button code 6: 294
    Button code 7: 295
    Button code 8: 296
    Button code 9: 297
    Button code 10: 298
    Button code 11: 299
    Button code 12: 300
    Button code 13: 301
    Button code 14: 302
    Button code 15: 303
    Button code 16: 704
    Button code 17: 705
    Button code 18: 706

    Both the number of axis and buttons differ, but all the PS1 buttons map to something. I don't understand why any PS[1,2,3] (even non dual shock) gamepad would ever have less than 14 total buttons.
    The recalbox version I've been using came from a pre-built image:
    -=============================
    head /recalbox/recalbox.msg
    v4.0.0-beta5

    • Updated libretro mame 2003 core. Fixes the ratio issue in mame.
    • Improved pads and gpio support for moonlight
    • Change location of PM2_HOME to fix a bug with API daemon
    • Disable printer sharing to reduce log output
    • Prevent MacOS from adding its .DS_store

    Is there something I can identify in this v4 build that I can roll into v6 will regain the working behavior?
    Is there a known procedure I'm missing to utilize a PS1 DS controller in recalbox 6?

    This is the adapter I'm using:
    -=============================
    Mcbazel PlayStation 2 Controller to USB Adapter for PC or Playstation 3 Converter Cable for Sony DualShock PS2 PS3 Controllers (NOT compatible with Dancing Mat Guitar Hero) - https://smile.amazon.com/gp/product/B000NJBD90/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1



  • I verified stock 4.0.0-beta5 (recalboxOS-4.0.0-beta5.zip) works with my adapter without any modification.

    The sdl2-jstest command oddly does not exist in this build though, which I don't understand.



  • The build I've been using which works, is actually [17.12.02] - 2017-12-02 so I'm guessing at least v4.0.0-beta5 - 2017-12-02 work with my adapter.

    It looks like "head /recalbox/recalbox.changelog" is the correct command to see the version while /recalbox/recalbox.msg is old/invalid.


  • Global moderator
    Team

    Hello @MagNeato

    you are using an old version of recalbox which is no longer supported. we don't support anymore

    Please update your version, it may solve all the problems.

    Check this tutorial : https://github.com/recalbox/recalbox-os/wiki/PS3-controllers-drivers-(EN)

    Edit recalbox.conf with winscp + notepad++ or via share network.

    Try bluetooth, official or shanwan driver :

    controllers.ps3.driver=shanwan
    controllers.bluetooth.ertm=1
    


  • Thank you for the reply.

    The PS1 controller works in the old version (4.x) . Some PS1 controller buttons do not work in the latest version (6.1.1). To few buttons are detected, as seen in the sdl2-jstest output.

    I tried your suggestion in 6.1.1, and see that both 6.1.1 and 4.0.0-beta5 are both using:

    /recalbox/share/system/recalbox.conf :
    controllers.ps3.driver=bluez

    I tried "official" and "shanwan" in 6.1.1, but it did not help.


  • Global moderator
    Team

    I tried "official" and "shanwan" in 6.1.1, but it did not help.

    you need to forget and reboot recalbox
    every time you change the driver
    and reconfigure gamepad.

    @acris said in PS1 DualShock controlle:

    controllers.bluetooth.ertm=1

    forget gamepad,
    reboot recalbox
    configure gamepad again.

    if doesn't work , please post archive support recalbox 6.1.1 only



  • controllers.bluetooth.ertm

    This is a USB adapter (not bluetooth). Does the setting apply to USB?

    Here is the support file from 6.1.1:
    https://www66.zippyshare.com/v/HkKSvvki/file.html

    I can't complete the 'configure gamepad' process because the X, O and Square buttons do not register button-presses.


  • Global moderator
    Team

    @magneato said in PS1 DualShock controlle:

    This is a USB adapter

    which adapter exactly ? link ?



  • There's an Amazon link for it in my first post.


Log in to reply
 

Want to support us ?

165
Online

78.5k
Users

20.1k
Topics

147.5k
Posts