Recalbox 7.0

XBox 360 wired controller analog stick issue



  • hi there again, this is some sort of system-crippling issue related to the wired XBox 360 controller, and more precisely the left analog stick. (Didn't try with the right one but since the left one should be handling character movement, I think it's pretty critical by itself.)

    I've tried 2 games so far, on 2 different systems: Metal Slug on FBNeo and TMNT: Hyperstone Heist on Mega Drive. Both give me the same problem, which is: when I move the left analog stick in any direction, the whole system softlocks, the character proceeds on the last direction selected and no input is being accepted, be it from controller or from keyboard - yeah, switching to keyboard doesn't help either. Disconnecting and reconnecting the controller by far only worked on picodrive, and maybe thanks to sheer luck, because on FBNeo it didn't work.

    I still haven't tested this issue thoroughly and didn't dig deeper in the config files, though I did reconfigure the controller via the standard Recalbox controller config menu, at least twice, to no avail. Every other input works pretty much flawlessly. If I touch the left analog, recalbox goes nuts. I still didn't run evtest to see what happens, but I plan to, to rule out kernel problems. The very same controller works fine everywhere else - PC or RPi3B with Retropie.

    Using DragonBlaze 6.1.1 on Raspberry Pi Zero v1.3 (NO network hardware).



Want to support us ?

123
Online

79.1k
Users

20.3k
Topics

149.1k
Posts