Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Lag avec les Hotkeys



  • Salut à tous.
    Tout d'abord, merci à toute la communauté pour son investissement et son aide. Je suis nouveau dans le domaine, il y a un mois en arriere je n'avais meme jamais entendu parlé de RecalBox ou meme de Raspberry.

    Ceci étant, grace aux nombreux tutos je me suis rapidement décidé a acheter le matériel pour monter une petite box. Résultat très satisfaisant pour émuler NES/SNES/MEGADRIVE/NEOGEO/PSX.

    Les problemes sont apparus lorsque j'ai changé de carte micro SD pour plus de capacité: lors de l'utilisation des combinaisons Hotkeys (save, load, accelerer) les jeux se mettent à ramer terriblement pendant plusieurs secondes (jusqu'à 10sec, avec les FPS qui chutent à 20-30 f/s) et ce quelque soit l'émulateur.

    Ci dessous l'historique des tests:

    Test 1
    Raspberry PI 3B+, dissipateurs thermiques, manette Logitech USB
    Alim Aukru micro USB 5V 3A
    Carte microSDHC LEXAR 16GB class10 (qui trainait chez moi).

    Aucun soucis! Testé sur NES/SNES/MEGADRIVE/NEOGEO/PSX. Les roms sont fluides, combinaisons Hotkeys fonctionnent parfaitement, les save/load sont rapide. Fonctionnement parfaitement satisfaisant. Je décide de changer de carte SD pour plus de capacité après avoir terminé les tests de configuration et de ROMs.

    Test 2
    Raspberry PI 3B+, dissipateurs thermiques, manette Logitech USB
    Alim Aukru micro USB 5V 3A
    Carte micro SDHC Sandisk ultra 32GB class10 A1 (neuve, achetée sur Cdiscount).

    Après avoir formaté par prudence la nouvelle carte SD, j'installe mes roms NES/SNES/MEGADRIVE/NEOGEO/ et 1 rom PSX pour tester.
    Je commence avec Metal Slug X. Résultat: Etant un peu impatient, j'utilise la fonction Hotkey accelerate pour diminuer les attentes. Le jeu se met à ramer terriblement. Jusqu'à etre pratiquement injouable. Le meme phénomene est constaté sur les autre ROMs. Les jeux sont toutefois fluides sans l'utilisation des Hotkeys.
    Un peu frustré, je change de carte SD pour remettre la 1ere de 16GB

    Test 3
    Raspberry PI 3B+, dissipateurs thermiques, manette Logitech USB
    Alim Aukru micro USB 5V 3A
    Carte microSDHC LEXAR 16GB class10 (qui trainait chez moi).

    Je laisse refroidir la bete, puis je test.
    Le probleme persiste, ce qui est un mystere absolu pour moi car le Set Up était parfaitement fonctionnel avant.

    Après plus d'investigation, voici en synthese les probleme/observations:
    Les roms sont fluides sans utilisation des Hotkeys (FPS = 60/s)
    Le CPU chauffe à 55°C, et l'utilisation des Cores est à 100%
    Si utilisation des Hotkeys save/load/accelere, les jeux lag pendant plusieurs seconde (FPS = 20-30/s)
    La durée du temps de lag parait variable selon les emulateurs (de quelques secondes jusqu'à 10-15sec)
    Etrangement, le fait d'utiliser la hotkey accelere durant le lag freeze le jeu environ 1sec puis rétabli le framerate ... Meme constat si utilisation de la hotkey quitter (hotkey+start)
    Le probleme est parfaitement recurrent, pas moyen d'y couper.

    N'ayant pas trouvé de sujet similaire sur le forum, ni sur Google ou Youtube, je m'en remet à vous.

    En balayant les différents forums, j'ai régulierement trouvé des sujets ou la premiere réponse était du style "une recherche sur Google/lire le mode d'emploi t'aurai permit de trouver facilement...", alors j'anticipe un peu mais je vous assure que j'ai fait pas mal de recherche de mon coté lol. J'ai résolu tous mes autres problemes de cette façon, mais là je seche.

    Merci à ceux qui prendront la peine de lire mon roman et de m'apporter leur aide.





  • T'as essayé avec ta sd d'origine (qui fonctionne bien) et avec tes roms sur clé USB ?

    Ça peut être une solution pour augmentons espace de stockage et ça a de multiples avantages



  • Je suis en train d'y penser (en partant du principe un peu frustrant que si j'avais essayé sans changer de carte SD j'aurai pas eu de probleme x).

    Ceci dit ca ne resoudra à priori pas le probleme vu que le probleme est maintenant récurrent avec les deux cartes SD (et ce malgré des resets ou ré installation ...)



  • Bon, après avoir testé avec:
    -carte SD d'origine (16 Gb)
    -Recalbox (version 6.1-DragonBlaze) réinstallé
    -Stockage externe (Clé USB 64 Gb)

    Les problemes restent les memes, à savoir la boucle suivante:
    -L'utilisation des Hotkeys entrainent un lag important
    -Le lag persiste jusqu'à la prochaine utilisation des Hotkeys
    -La prochaine utilisation des Hotkeys ne fonctionne pas, mais rétablie la vitesse du jeu

    Une idée, quelqu'un?



  • @otis pour continuer ton diagnostic, et écarter le problème matériel que du coup je soupçonne fortement, il faudrait que tu teste sur un autre raspberry si c'est possible...



  • Finalement personne autour de moi ne dispose d'un autre raspberry, du coup pas possible d'en être sur à 100% mais par élimination je suspect moi aussi un problème matériel...

    Je pense en racheter un pour en avoir le cœur net.

    Reste la question (certe relativement vaste): qu'est ce qui peut avoir endommagé un raspberry neuf ?
    Il n'a subit aucun choc, et très peu de hard reset (2 ou 3 dans sa courte carrière).


  • Staff
    Moderator
    Team

    Court-circuit via la prise microsd
    j'ai bousillé un rpi3 de cette façon il a pris quelques courts circuits quand je débranchais la prise électrique



  • Damned, ca parait totalement possible ...
    Mais du coup comment éviter le probleme? Je pensais à ajouter un bouton "ON/OFF" à mon boitier, un peu comme celui sur les NESPI case et autre, mais sans ça comment se proteger des court-circuit et autre?


  • Staff
    Moderator
    Team

    en évitant de débrancher....
    il existe des câbles microusb avec un bouton on/off.



  • Ou tu peux tout simplement debrancher au niveau de la prise électrique, ce qui a en plus l'avantage de ne pas laisser traîner un câble branché


Log in to reply
 

Want to support us ?

171
Online

62336
Users

18666
Topics

140196
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.