Retrouver un vrai 4/3



  • Bonjour, je suis sous recalbox 6.1 avec un raspberry pi 3b+, j'ai installé comme le veut le tuto les overlay et tout fonctionnai bien, sauf qui finalement je dispose d'un bartop et d'un écran 4/3 et donc j'ai supprimé tout les fichiers dédié aux overlay mais je me retrouve avec des bandes noires malgré un écran 4/3. J'ai beau réglé en 4/3 dans retroarch ou sur émulation station rien n'y fait, à part mettre en 16/9 ce qui rempli l'écran mais n'est pas le format d'origine... Par contre la dreamcast ne pose pas de souci.

    Avez-vous une solution s'il vous plaît?

    2_1570267537287_72084962_763232754114642_5831207609503318016_n.jpg 1_1570267537287_71540979_675431696311164_4501963042967257088_n.jpg 0_1570267537286_71339548_931369893890131_6564107868344156160_n.jpg


  • Staff
    Global moderator
    Team

    Bonjour @marwin91
    as tu réglé correctement les options de la video dans recalbox.conf ?
    et/ou désactiver le pixel perfect dans les options

    Déterminer la résolution de ton écran :

    tvservice -m DMT

    Puis mettre l'information dans recalbox.conf

    /!\Attention l exemple et pour un écran 5/4

    # ------------ H - HERE IT IS - GLOBAL EMULATOR CONFIGURATION ------------ #
    ## The global value will be used for all emulators, except if the value
    ## is redefined in the emulator
    
    ## Set game resolution for emulators
    ## select your mode from the command : tvservice -m [MODE]
    ## CEA 5 HDMI : 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced 
    ## CEA 4 HDMI : 1280x720 @ 60Hz 16:9, clock:74MHz progressive
    ## use 'default' for using the default resolution
    ## use 'auto' : switches to CEA 4 HDMI if supported, else keep the current resolution
    ## (string)
    global.videomode=DMT 35 HDMI
    

    Puis mettre

    ## Set ratio for all emulators (auto,4/3,16/9,16/10,custom)
    global.ratio=4/3
    


  • J'utilise un écran branché avec un adaptateur hdmi/vga, dans le recalbox.conf j'ai la même config que toi sauf pour le global.video mode ou je suis en CEA 4 HDMI, mon global.ratio est bien en 4/3. Comme tu peux le voir dans les photos que j'ai uploadé le pixel perfect est bien désactivé.

    Voici mon recalbox.conf :

    ------------ H - HERE IT IS - GLOBAL EMULATOR CONFIGURATION ------------

    The global value will be used for all emulators, except if the value

    is redefined in the emulator

    Set game resolution for emulators

    select your mode from the command : tvservice -m [MODE]

    CEA 5 HDMI : 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced

    CEA 4 HDMI : 1280x720 @ 60Hz 16:9, clock:74MHz progressive

    use 'default' for using the default resolution

    use 'auto' : switches to CEA 4 HDMI if supported, else keep the current resolution

    (string)

    global.videomode=CEA 4 HDMI

    Shader set

    Automatically select shaders for all systems

    ## (none, retro, scanlines)
    global.shaderset=none

    Once enabled, your screen will be cropped, and you will have a pixel perfect image (0,1)

    global.integerscale=0

    Set gpslp shader for all emulators (prefer shadersets above). Absolute path (string)

    global.shaders=

    Set ratio for all emulators (auto,4/3,16/9,16/10,custom)

    global.ratio=4/3


  • Staff
    Global moderator
    Team

    @marwin91
    modifie comme indiqué



  • Merci beaucoup, problème réglé! J'adore la 6.1, vous nous régalez.


Log in to reply
 

Want to support us ?

239
Online

80.5k
Users

21.6k
Topics

158.0k
Posts