Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

My experience so far with recalbox on odroid c2



  • First off, let me start with stating that I have been using recalbox on an RPI2 for years. It has been great! I have had multiple PS3 sixaxis controllers connected and working... and it has been awesome. From time to time, I notice some slowdown, as to be expected with an RPI2.

    I got my hands on an odroid c2. I have tried both with sdcard and emmc as the local storage. In both cases, and written with the same image, I can not get the sixaxis controllers to pair via the same BT 4.0 dongle I had been using in my RPI2 setup. I tried another one, also to no avail. I even went as far as to set the devices into pair mode, and then connect via usb. I have followed the setup and configured the keys etc. after every reboot, the controller settings are unknown. after the first reboot, the SSH service seems to not start. I lose ability to connect and nmap shows a number of other services running on the box, but no SSH.

    I am not sure If the process is different, but here's what I have always done on an RPI if I needed to "rebuild". delete the partitions on my sdcard. Write the image either via an appimage of etcher, or using dd. boot in the device. once at the normal menus, connect ps3 controller via usb cable - wait about 10 seconds or more, then disconnect and pair. this has never failed me. Then, migrate through menus, set storage to external. restart. Then ssh, and add samba lines to the /boot/recalboot.conf file (i think that's its name) which allows for using network shared games. reboot, enjoy.

    I can not get the sixaxis controllers to pair, and I used a pin to reset them as well. not sure where to start looking since I seem to lose ssh. as I said, I have written the same image to sdcard, as well as emmc, to see mostly if the issue was related to my use of an emmc......

    any next steps, or an idea where too look? lsusb sees my usb bt dongle, and dmesg | grep usb will show the sony controllers while connected via usb, but I see no messages or anything that relate to why this is effed. am almost thinking it has put some part of the filesystem in a read-only mode, and its more of the filesystem than should be.



  • @boblablah

    so I did this again, with the image on SD card. Booted the C2, with the BT 4.0 dongle plugged in that works fine on a RPI2 with recalbox.

    Anyways, the sixaxis pairing doesn't report to work, but there are a few buttons that do work, and they are all messed up. L2 and R2 are up and down. Select is Start. That is it. none of the analogs, or the directions pads work. and most of the buttons don't register a reaction, let alone do what they should



  • another update. It seems as though when I reboot the C2, ssh is no longer a service.

    nmap 192.168.10.110
    Starting Nmap 7.70 ( https://nmap.org ) at 2019-10-01 14:08 CST
    Nmap scan report for 192.168.10.110
    Host is up (0.00025s latency).
    Not shown: 996 closed ports
    PORT STATE SERVICE
    80/tcp open http
    139/tcp open netbios-ssn
    445/tcp open microsoft-ds
    8080/tcp open http-proxy
    MAC Address: 00:1E:06:33:66:8C (Wibrain)

    This is the output nmap detects as active open ports... no ssh. not sure why. Again, the last build I had was dragonblaze 6.0 on an RPI2 with this same usb BT dongle, and my ps3 sixaxis controllers all worked fine.



  • I was able to get the controllers to pair. but they don't indicate successful pairing now. No light is on. annoying to say the least. also, this build of recalbox runs PS1 games slower on the odroid c2 - by rights significantly more powerful than an rpi, worse than an rpi2.



Want to support us ?

175
Online

78.5k
Users

20.0k
Topics

147.5k
Posts