Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Après une installation de Recalbox 6.1, mes GPIO ne sont plus détectés



  • Bonjour,
    J'ai un Bartop avec deux contrôleurs GPIO (stick + 6 boutons + Start + Select) qui jusqu'ici fonctionnaient parfaitement sous Recalbox 6.0.
    J'ai flashé une nouvelle carte SD avec la version 6.1, en suivant les instructions officielles de Recalbox.
    Au lancement, les GPIO ne sont plus détectés.
    En allant dans le fichier recalbox.conf, je remarque les lignes suivantes :

    # ------------ D2 - GPIO Controllers ------------ #
    ## GPIO Controllers
    ## enable controllers on GPIO with mk_arcarde_joystick_rpi (0,1)
    controllers.gpio.enabled=0
    ## mk_gpio arguments, map=1 for one controller, map=1,2 for 2 (map=1,map=1,2)
    controllers.gpio.args=map=1,2
    

    J'effectue la modification suivante :

    controllers.gpio.enabled=1

    Je reboote, mais étrangement les GPIO ne sont toujours pas détectés.
    Quand je retourne dans recalbox.conf, je retrouve la ligne d'origine :

    controllers.gpio.enabled=0

    Je ne comprends pas pourquoi mes changements sont effacés à chaque lancement.

    Merci par avance de votre aide.


  • Global moderator
    Team

    Bonjour
    il y a 4 sujets sur les gpio , un effort t'aurait indiqué un bug a été détecté : https://forum.recalbox.com/topic/18847/configuration-des-touches-via-gpio

    merci d'être attentif.



  • Ambiance ambiance... 🙂
    Un membre du staff m'a demandé de poster un message ici.
    Dont acte.


  • Global moderator
    Team

    @Darth_Elessar
    tu modifies via recalbox manager ? tu edites via ssh & nano ? tu édites via winscp et notepad++ ?



  • @acris J'ai testé plusieurs techniques : notepad, winscp ou directement via ssh.

    Petite précision, j'ai testé deux configurations.
    Dans l'une, j'ai mis à jour mon 6.0 en 6.1 directement sur le bartop (raspberry pi 3).
    Dans l'autre, j'ai flashé une carte micro SD 128 Go sur mon PC, en suivant le tuto officiel, et je l'ai placée dans le bartop.

    Pour la mise à jour de mon ancien 6.0 en 6.1, les GPIO fonctionnent, mais je n'ai pas d'image lorsque je lance un jeu.
    Pour la nouvelle installation sur la carte Micro SD vierge, les GPIO ne fonctionnent pas (et le fichier .conf ne se modifie pas durablement), et j'ai des problèmes d'affichage en jeu, avec une zone qui ne remplit pas tout l'écran et est décalée sur la gauche, peu importe le système émulé.

    Merci


  • Global moderator
    Team

    Tu as essayé de copier le fichier sur ton pc, le modifier et le retransferer vers ta recalbox ?

    Sinon, un peu a été trouvé sur les gpio est c'est en cours de resolution..


  • Global moderator
    Team



  • Hello,

    Merci pour le message.
    J'ai suivi toutes les indications, mais lorsque je tape cp /recalbox/share/recalbox_settings /usr/bin, il me répond :
    can't create [...] : file exists.
    J'ai essayé de monter votre partition racine en écriture en tapant mount -o remount,rw /boot mais ça ne fonctionne toujours pas, même après un redémarrage.
    Je dois mal m'y prendre quelque part.


  • Global moderator
    Team

    Ce nest pas la partion boot à monter en ecriture mais la partiton system.
    Si il existe supprime le ou utilise winscp pr le transfere du fichier toujours en ayant monter la partition

    mount -o remount,rw /



  • J'ai suivi les consignes, je n'ai eu aucun message d'erreur, mais les GPIO ne fonctionnent toujours pas.
    Merci quand même.


  • Global moderator
    Team

    @Darth_Elessar
    Poste ton rexalbox.conf

    Tous ceux qui ont des problemes gpio ont resolu le probleme avec le fichier fourni par @Bkg2k



  • moi avec recalbox manager je ne pouvais pas mais j ai modifier le fichier du pc et recopier et ca a fonctionner mais moi je suis sur cles usb pas sur carte sd



Want to support us ?

131
Online

78.7k
Users

20.2k
Topics

147.9k
Posts