Recalbox 7.0

Désactivé les Shaders pour 1 seul systeme quand on est en Rétro ?



  • Bonjour,

    Voici mon cas: en parametre général pour les shaders-set je suis en retro
    Mais voila pour Doom (prboom) j'ai découverte qu'en forcant la résolution interne en 960x600 (pas au dela, ça rame sinon) , le jeux est magnifique !
    Par contre les shaders pré-programmé gache l'affichage du coup (crt_caligri...)
    Donc mon but est de rester en shaders-set RETRO pour tout mes systemes SAUF pour prboom.

    J'ai essayer plusieur manip dans Recalbox.conf et prboom.cfg (fichier d'overlay) parmis lesquels:

    prboom.shaders=none
    prboom.shaders=0
    video_shader = "false"
    video_shader = "0"

    Rien n'y fait, soit le jeu refuse de démarrer, soit le shader "crt_caligari..." est actif...

    Vous avez une idée s'il vous plait ?


  • Banned

    @jrbaka cherche retro dans to ficher recalbox.conf, c'est pas shaders mais shaderset ou quelque chose comme ça.

    et c'est pas none ou 0 mais \ ou / je crois, mais bon la dernière fois que j'avais essayé en 4.1, ça ne marchait plus de désactiver avec cette syntaxe



  • J'ai essayer:

    prboom.shaders=/
    prboom.shaders=\

    Ça plante


  • Banned

    @jrbaka bon essaye de lire quand même mon message en entier on sait jamais 😉



  • Set the retro shader set for all emulators, now i know that i have the best selection

    global.shaderset=retro

    But my gameboy seem better for me with no shaders

    gb.shaders=

    And i want to apply my own shader preset on snes

    snes.shaders=/recalbox/share/shaders/custom/snes.glslp

    Shaderset c'est pour l'ensemble, moi je ne veux changer qu'un seul systeme


  • Banned

    @jrbaka oui enfin si tu mets qu'un système et pas global genre snes.shaderset c'est pas pour l'ensemble...



  • Ok donc selon toi il faudrais que je commence par:

    prboom.shaderset=

    Je testerais des que je peut, je ferai un retour


  • Banned

    @jrbaka quelque chose comme prboom.shaderset=/ mais comme dit plus haut, la fonctionnalité était cassé en 4.1



  • @voljega said in Désactivé les Shaders pour 1 seul systeme quand on est en Rétro ?:

    prboom.shaderset=/

    Non... le filtre est toujours présent...


  • Banned

    @jrbaka alors attends je viens de vérifier dans mes notes en fait en ayant global.shaderset=retro activé il fallait faire ça : psx.shaders=/ pour que ce soit désactivé pour un système spécifique...

    mais bon comme je l'ai dit, j'avais déjà constaté que ça ne marchait plus en 4.1, ça marchait bien dans les versions d'avant, surement que ça doit être pété en 6.0 aussi



  • @voljega said in Désactivé les Shaders pour 1 seul systeme quand on est en Rétro ?:

    .shaders=/

    Non, là, ça plante...

    Au pire, il n'y a pas un moyen de contourner l'obstacle en mettant le nombre de passe a zéro ?
    Dans le .conf ou le prboom.cfg (fichier d'overlay) ?


  • Banned

    @jrbaka ça je n'en sais pas plus sur le sujet....



  • C'est bon, j'ai trouvé le moyen de désactiver le filtre d'un seul système alors que le shaderset est sur RETRO !
    Voici comment j'ai fait:

    J'ai crée un shader nommé no_shaders.glslp contenant seulement "shaders = "0" (c'est le nombre de passe en fait).
    Ensuite je l'ai mis avec les autres shaders grace a WinSCP.

    Perso, dans le fichier d'overlay prboom.cfg j'ai inscrit la ligne:
    video_shader =/recalbox/share_init/shaders/no_shaders.glslp

    Pour ceux qui veulent faire la même manip mais l'inclure dans recalbox.conf il faut y mettre:
    prboom.shaders=/recalbox/share_init/shaders/no_shaders.glslp



  • A titre de comparaison, voici 2 screenshot de Doom 2 avant et apres modification de la résolution interne dispo dans le menu retroarch -> option

    Résolution de base:
    0_1557561731652_Doom 2 french-190511-094427.png

    En 960x600:
    0_1557561764711_Doom 2 french-190511-094300.png

    Pas la peine d'essayer les résolution au dessus, ça rame grave.



Want to support us ?

206
Online

79.1k
Users

20.3k
Topics

149.1k
Posts