Recalbox 7.0

recalbox.conf n64.videomode not working



  • Running the 64 bit image on a Gigabyte brix mini pc. My issue is that everything tries to run at 1080p some of the more power hungry emulators struggle to be stable at that resolution.

    I've tried using the n64..videomode=DMT 35 and various other settings. All that happens is that it doesn't start up.
    Nothing seems to work, and when I try to use tv service it always optputs this..

    [
    { "code":1, "width":1920, "height":1080 }
    ]

    regardless of what parameters i feed in. Any ideas why this is happening? And how to solve it?



  • I've found out some information but still can't work how to do what I want.

    This page explains that the tvservice doesn't work on pc's its just a hack to stop crashing.

    I found this on the wiki detailing how to change the display resolution.
    https://github.com/recalbox/recalbox-os/wiki/Change-display-resolution-on-x86---x86_64

    This is a global change and I would like to be able to set a per emulator resolution. I imagine this could be done using a launch shell script to call xrand and then open the emulator.

    How does recalbox do this normally?
    Is there any way to edit the existing launch commands to insert an xrand command?


  • Local Moderator

    @kyuzumaki Have you tried editing the file SHARE \ system \ configs \ mupen64 \ mupen64plus.cfg?
    There is a [Video-General] section, and a section for each core type chosen: [Video-Glide64mk2] or [Video-Rice].
    I do not know if it solves your problem, but it's an option.



Want to support us ?

158
Online

79.1k
Users

20.3k
Topics

149.0k
Posts