Save state problem



  • Hello, since a few days, the gameboy emulator in recalbox will refuse to load/save states for some games. When I press the "load" or "save" hotkey, the following message is shown: "Failed to save state to /recalbox...". This only applies to certain games. In other games, the savestate work fine. I tried to delete the *.state file from the saves directory, but this does not fix the problem. I assume it might either a a filesystem corruption or a permission issue? Does anybody know how to fix this?



  • I have exactly the same problem in the Super Nintendo emu for a few days now. I played Zelda 3 very frequently over the last 2 weeks saving and loading states a lot and suddenly I get the same error Nils. Save and load don't work anymore in the game, what can it be?


  • Moderator
    Team

    In recalbox beta 16 ? If yes, remap controller in emulationstation.



  • It's beta 14 for me. I remapped the Xbox Controller but it didn't get any better. Now I updated to beta 16 but still the same (also remapped controller).



  • Ok, I'm almost sure it has to do with my "cheap" sd-card. I use a SanDisk Ultra and many people seem to have problems with it after a few days. I sshed into the box and noticed that with every reboot the sd-card is mounted randomly as read/write or read only. Though the save states also won't load when mounted rw I'm sure it has to do something with reading/writing to the card in general. I ordered a Sandisk Extreme now, hope the problems will be gone then.



  • Thanks god I'm not alone with this problem. I'm also using the latest beta(16), remapping the controller did not fix the problem for me. The controller buttons are working fine, I'm seeing an error message that save/load failed. Also interesting is, that in some games it work, in others it doesn't.   Isn't there any possibility to check the filesystem for problems/corruption?



  • Nils, what is the brand/model of your sd-card? For me it also works with some games, with others it doesn't. I played Zelda for at least 2 weeks without any problems, now it doesn't load/save anymore, but I also played Harvest Moon (both SNES), which still works fine. I also have problems to copy files over to share/roms/ from time to time. I didn't give much about it cause the other day all copying works fine again, but those are exactly the problems people get with "cheaper" sd-cards. As I know now my SanDisk Ultra series and also some Transcend seem to make problems.



  • Today I installed beta 16 on a SanDisk Extreme 16GB, copied all my roms and save states from the old card and now everything works fine.



  • yes seems to be sd card related. I had a micro sd card branded "paradies". I copyed the whole installation over to a new transcend card, and it seems more stable. Have to do more testing. I never had problems with openelec or any other application on the old sd card before.


  • Moderator
    Team

    Yes indeed, it is corruption problems with your SDcard. We recommand the sandisk cards on rpi. Openelec is a system on read-only, no corruptions problems. Recalbox is not on RO (should be in the next major version), so be carefull with your SD card quality, and you must EVERYTIME shutdown the system using the menu. Never unplug power supply to shutdown it. If you have a pc under linux and corruption problem (you share partition in RO etc...) you can try to do fsck on your sd card.



  • after 2 weeks of fine work without problems, my new sd card got corrupted again. Have to buy another one (thank you for the tip to use "sandisk"). In my opinion the root read only filesystem is high prio! Many other people should experience similar problems. Is there a way to store the saves on a mounted nfs network share?



  • I followed this guide to setup a permanent nfs folder share for the saves. This works fine for me.



  • I solved the "Failed save state". For me it was the problem that the save folder turned into "read-only". I did this: 1. Got to recalbox-directory: cd /recalbox 2. re-mount the folder "/share" as read&write: mount -o remount,rw share/ Now "share/" is read&write again and I can save additional info: ( save/-directory is within the share/ directory)


Log in to reply
 

Want to support us ?

Join us on :

310
Online

25533
Users

13361
Topics

101256
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.