Amiga: comment désactiver l'acces au menu avec "Start" ?



  • Bonjour,

    Je joue aux jeux Amiga qui se joue uniquement a au joystick.
    Souvent par réflexe j'appuie sur Start sauf que ça affiche le menu de l'émulateur, résultat je suis obliger de brancher une souris pour pouvoir en sortir.
    J'ai vu sur le github "Amiga sur Recalbox (FR)" que l'on pouvait éditer les fichiers .uae afin de personnaliser quelque touches dont le bouton menu. Le code de base est le suivant:

    ;hardware
    chipset=aga
    chipmem_size=4
    cpu_speed=max
    cpu_type=68040
    cpu_model=68040
    fpu_model=68040
    fastmem_size=8
    ;controls
    config_version=2.8.1
    joyport0=mouse
    joyport0autofire=none
    joyport0mode=mouse
    joyportname0=MOUSE0
    joyport1=joy0
    joyport1autofire=normal
    joyport1mode=djoy
    joyportname1=JOY1
    input.autofire_speed=0
    input.mouse_speed=100
    button_for_menu=2
    button_for_quit=3
    ;graphics
    gfx_width=640
    gfx_height=256
    gfx_correct_aspect=true
    gfx_center_horizontal = simple
    gfx_center_vertical = simple

    A la ligne "button_for_menu=2" j'ai changer la valeur par plein de trucs (none, false, 0, 999, etc...) mais ça ne désactive toujours pas la touche Start.

    Vous auriez une idée s'il vous plait ?


  • Themer

    @jrbaka hmm normalement j'aurais pas du laissé la conf des boutons menu et sortir dans le UAE, j'ai du me tromper, du coup de toute façon elles doivent être écrasées par le code au lancement de l'émulateur.

    il faut que tu édites /usr/lib/python2.7/site-packages/configgen/generators/amiberry/amiberryController.py toute à la fin du fichier je pense (en remontant / en écriture)



  • Effectivement @voljega C'est bien ça .

    J'ai éffacé la ligne: "fUaeConfig.save("button_for_menu",selectId)"
    Et la touche start n'affiche plus le menu.

    Merci beaucoup pour ton aide.



  • bonjour,

    comment as tu fait pour supprimer la ligne ?
    Le fichier est en read-only, impossible de changer les droits avec chmod, je suis bien en root.
    je passe via ssh
    avec un simple "vi" pour l'éditeur
    merci de ton retour


  • Themer

    @sebastien-brossard "en remontant / en écriture" mount -o remount, rw /



Want to support us ?

Join us on :

260
Online

28949
Users

14692
Topics

110945
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.