Xbox One Controller (via USB) and N64 (mupen64plus)



  • Hi guys,

    I am using the latest Recalbox version (18.07.13), also trying to make Xbox One controller to work correctly regarding the button mapping while using it with N64 emulation (using mupen64plus core).

    Gamepad is correctly recognized under Emulationstation, button mapping is fine and even on any other emulator cores (libretro).

    The problem I am facing is that using the Xbox One controller via USB with N64 emulator (mupen64plus), button mapping is wrong.

    For example, Z-Trigger is mapped to the right stick (right side direction) instead to be mapped to L-Button or L-Trigger on the Xbox One controller.

    I tried to add my custom file (InputAutoCfg.ini and also adding n64.configfile=dummy line to recalbox.conf) but I can not make button mapping to work as expected.

    I tried to run the N64 emulation using libretro core, mapping is correct and fine, but this core is sloooowwww, so it is unplayable :(

    Any suggestions or help?

    Thanks so much guys!!!



  • exactly same problem L-joystick its ok in FPS like goldeneyes but when i try other type of game (example v-rally ) my mapping doesn't match with i've made its R-joystick use to move but i have config L-joystick to do this .



  • Hi guys!

    Finally I got the solution for that. What I did is to move from mupen64plus to libretro core (mupen64 but from libretro) under the N64 emulator settings to use.
    Key mapping is now working as expected using Xbox One controller.
    The problem about slowness (using libretro - mupen64) was caused because I already set libretro snes9x to use run ahead (latency settings) and saved the configuration, so N64 emulation was also trying to use run ahead settings that are quite bit processor intensive.
    I just disabled run ahead (lantency settings) for this N64 core only, and now I am ready to go!

    Thanks!


Log in to reply
 

Want to support us ?

Join us on :

283
Online

31256
Users

15144
Topics

113902
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.