Problème emulationStation ne redémarre pas après avoir quitté un jeu (RPI1)



  • Bonjour,

    Tout d'abord, merci pour Recalbox.

    J'ai recherché sur le net des solutions à mon problème mais aucune ne le corrige à ce jour.

    J'utilise recalbox dernière version (26 juin 2018) sur un Rpi 1.
    Ma carte SD fait 16 Go. La partition des roms est pleine à 25%.
    le RPI est overclocké en mode extrem.
    Il est connecté à l'écran de mon PC en HDMI.
    Je pourrai donner plus d'infos techniques si besoin.

    Après le splash screen initial, ES se lance bien au démarrage, je peux choisir le jeu que je veux lancer depuis le menu.
    Tous mes émulateurs fonctionnent bien (neogeo, amstrad, sega, ...).
    Les jeux se lancent bien et je peux jouer sans problème.

    Mais systématiquement (vraiment à chaque fois), lorsque je quitte le jeu en cours (par la combinaison de touches Hotkey + Start), j'arrive sur l'écran noir avec le dessin d'une manette blanche en bas au centre de l'écran et le numéro de la version de la recalbox.

    EmulationStation n'est pas relancé (ou ne semble pas l'être).
    (confirmé lorsque je me connecte en SSH sur la recalbox : la commande 'TOP' n'affiche pas le process emulationstation alors que ce même process est bien présent après le lancement initial de la recalbox).

    J'ai essayé de lancer "à la mano" emulationstation après un retour depuis un jeu.
    L'écran de chargement d'ES apparaît, ça charge. A un moment, j'entends la musique 1 à 2 secondes puis tout se coupe et retour à l'écran noir avec la manette blanche en bas de l'écran.
    J'ai l'impression qu'il n'y a pas assez de mémoire, mais je n'en suis pas sur. (j'ai vu un outofmemory dans une des logs durant mes nombreux essais).

    Du coup, entre 2 jeux, je suis obligé d'aller sur mon PC, de me connecter via mon navigateur sur http://recalbox et de rebooter la recalbox pour avoir accès à nouveau à ES et pouvoir choisir un jeu à lancer. (ou de taper reboot depuis SSH).

    En dehors de ce problème, tout fonctionne comme je le souhaite.

    Si vous avez une idée de la solution à ce problème ou des demandes de passage de commandes ou de récupérations de logs pour aider à comprendre d'ou ça vient, ce serait avec plaisir.

    Mon PC est sous Linux.

    Bien cordialement,
    Laurent


  • Themer

    @thadoss tu utilises le theme standard ?



  • Oui. Tout est par défaut, j'ai juste désactivé les manettes bluetooth (je n'utilise pas).

    Je précise que j'avais exactement le même comportement avec la version précédente de recalbox (d'avril).
    J'attendais la nouvelle version avant de poster mon problème.
    Laurent



  • @thadoss tu peux faire une archive de support stp ? De base sur pi1 il faudrait se passer des froufrous "web" ( iftuzl gamepad et webmanager), mais il me semble que c'est le cas



  • Voici le lien : https://file.ac/7rBhdLEOXQM/

    Merci à vous pour l'aide.
    Cdt,
    Laurent



  • @thadoss @substring Pardon, j'avais oublié de mettre le @pseudo dans ma réponse. précédente.



  • @substring bon, j'ai avancé dans mes recherches.

    Lorsque je quitte un jeu avec "Hotkey" + "Start", la recalbox revient à l'écran noir avec la manette blanche recalbox en bas au milieu (à chaque fois). Il ne se passe rien d'autre.

    La, je lance manuellement la commande :

    /etc/init.d/S31emulationstation restart

    Je vois affiché "do not power off the recalbox, ou qqchose comme ça", puis ES se recharge et je retrouve le menu.
    Je peux choisir un autre jeu (y compris d'une autre console) et le lancer.
    Bien sur, lorsque je quitte à nouveau le jeu, retour à la situation précédente, mais je peux à nouveau saisir la commande "/etc/init.d/S31emulationstation restart" pour retourner à nouveau sur le menu etc.

    J'ai essayé plusieurs fois de suite et ça marche.
    Le seul problème que ça génère est que je perds le son (plus de son dans les émulateurs).

    En résumé :

    • lorsque je quitte un jeu (HotKey + Start), ES ne se relance pas.
    • je peux le relancer manuellement depuis mon PC en SSH mais je perds le son.

    Voilà. J'espère que toutes ces manips permettront de mettre le doigt sur le problème (au moins de relance d'ES)

    Cdt,
    Laurent



  • Et un autre essai :

    J'avais retiré les musiques du menu dans les essais décrits dans mon message précédent.

    Je viens de remettre les musiques dans le menu et reboot de la recalbox pour prise en compte.

    La, j'ai bien le menu avec les musiques.
    Je choisis un jeu, il se lance.
    Je quitte le jeu : écran noir avec la manette blanche en bas de l'écran
    Je lance la commande "/etc/init.d/S31emulationstation restart" et ES commence à se charger, puis semble se planter et retour à l'écran noir avec la manette .

    A l'écran, dans la console, j'ai :
    lvl0: System "favorites" is missing name, path, extension, or command!
    lo IP Address 127.0.0.1
    eth0 IP Address 192.168.1.20
    ALSA lib pcm.c:8251:(snd_pcm_recover) underrun occurred
    ALSA lib pcm.c:8251:(snd_pcm_recover) underrun occurred

    Les 2 lignes avec ALSA sont nouvelles et ES semble se planter juste après leur affichage.

    Donc, en résumé de cet essai : avec les musiques activées dans le main menu, ES ne parvient pas à se relancer lorsque je le relance manuellement.

    Hope this help
    Laurent



  • @thadoss c'est le côté rpi1 qui m'inquiète ...



  • Il n'y a personne qui utilise Recalbox sur un Rpi1 et qui a le même problème ?

    Laurent



  • @thadoss faudrait que je teste ... mais plus de SD de dispo :/



  • @thadoss je promets rien (c est dimanche le jour de ma femme...)mais j ai un pi 1 si j ai le temps je fais une install propre et je post.Au pire des cas demain ce sera bon



  • Super, merci à vous.

    J'espère juste qu'on trouvera, je suis assez étonné de la qualité des jeux avec le rpi1 (je ne m'attendais pas à une telle fluidité).

    Bon week end,
    Laurent



  • @thadoss mince j avais une heure et j arrive pas a aller sur le site de recalbox et telecharge l iso...il doit etre en maintenance :( j ai un
    503 Service Unavailable
    No server is available to handle this request.
    Je pense que je testerai ca demain....



  • @mrseguin bizarre tjs le meme problème...
    Bon ben demain en espérant que j arrive a y accéder !



  • Allez direct sur archive.recalbox.com



  • @substring tjs bon a savoir :)



  • @thadoss Bon fresh install de la derniere version sur carte SD. Chargement et affichage plus lent qu avant mais pas de probleme de retour au menu en quittant un jeu.Je precise que je n ai installe aucune rom (j utilise les homebrews de base dans la disti recalbox) et que je suis uniquement sur la carte sd (pas de cle usb externe)



  • Merci pour ce retour.
    J'ai continué à chercher ces derniers jours sans succès.
    Tant pis, je vais prendre un Rpi plus récent.

    Merci encore à tous.
    Laurent



Want to support us ?

Join us on :

248
Online

28779
Users

14635
Topics

110632
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.