NETPLAY : SELECT not working anymore - feedback



  • Hey guyz,

    It seems quite a number of you are facing some problems adding credits in netplay, or even using the SELECT button. I'd need :

    • system
    • rom (if you can give its hash it's even better)
    • which pad were connected
    • if you were client/host
    • which player number you were

    Thank you for you help, I can't reproduce the problem on my own



    1. System: Raspberry Pie 3
    2. ROM: Hashed all done. fba_libretro and mame All games do not get a select button. (at netplay)
    3. GPIO 1P, 2P
    4. No Select button for Client / Host
    5. 2players


  • RbPi 3
    Any mame rom
    1P Bluetooth (8bitdo pad)
    select button don't work when i'm host, did not try on client
    1P

    Only happens in network, without network select works fine



  • @rizzie you don't have a dedicated hotkey ?



  • @substring I have the same problem, it seems to me that it has nothing to do with netplay. Even playing solo when using Super NES controls, I have to set the hotkey on the same button as the select. In some games of tFBA emulator (all CPS2 and NEO GEO) simply the select (coin) does not work.



  • @marcos-breviglieri i can provide a new retroarch binary if peopke are ready to test



    1. Raspberry Pi 3
    2. Any arcade rom, for example sf2ce.zip. As emulator, I use fba libretro
    3. The typical Buffalo Classic Snes Pad (using select as hotkey and as select button), 2 of them (player 1 and player 2). I also have a psx1 clone pad speedlink, it doesn't have the problem because the hotkey is addressed to a dedicated button. I use this one for the menus and kodi because it is wireless, but when I play, only the snes pads are working. If I remove them, then I can use the speedlink as player 1 without the select problem.
    4. I have the problem as client and as host. A special case is when I play without netplay. In this case, the select button for player one doesn't work, but the select button for player 2 does, so only in this case I am able to put some coins in arcade games.

    Thanks for your work, would be great if it works again soon.



  • @substring Yes I have specified the select button as hotkey.



  • @rizzie why haven't you wired a dedicated hotkey button ?



  • @substring If you need I'll do the test and give you feedback



  • @marcos-breviglieri ok. Are you a little familiar with linux ? Need to copy a file to /usr/bin and chmod too



  • @substring Yes, I am, you can send files for testing.



  • @marcos-breviglieri Download a new retroarch binary from https://we.tl/vMgfWfUjFk

    Replace the original one (make a backup) in /usr/bin and don't forget to chmod +x /usr/bin/retroarch



  • @substring I tested it in several games and it worked.



  • I tried the binary but it didn't work for me. With the new binary, the three gamepads are working fine on emulationstation menu, but as soon as I start any emulator, no gamepad responds. I added executable permission (chmod +x) to the new retroarch executable and the permissions of the new file are identical as the permissions for the backup, so it should be fine. I checked the md5sum, which seems to be right (cf9a5795fbfaf4f41c890743bbbbf393) so I suppose I have something wrong in the configs of my share folder. Maybe I'll try resetting those config folders (share/system), cause my recalbox shared folder is very old and was updated already several times.

    Thanks anyway for your effort!



  • Resetting the share/system folder to a vanilla copy that I have in another card didn't work well. The Emulationstation menu was working, but as soon as I started a rom, the screen stayed black forever and I had to restart it with a ssh signal using a raspberry pi app from my smartphone. I just reverted everything and now I am at the starting point again.



  • @tonificante you'd just need to remove ~/configs/retroarch, nothing more



  • @substring thanks, now I get a nice smooth font in retroarch, so it seems that the retroarch configuration has changed. Unfortunately I cannot use the hotkey anymore when I am playing a rom (I cannot enter into retroarch menu), although the coin function works, so I will stick to the standard retroarch binary. I also tried with the standard binary, then enter in retroarch and update joystick profile, then change to patched binary and run rom, but no luck. I will wait until next recalbox release for netplay or remove the snes gamepads and use only the ps1 clone pad for netplay.





  • Thanks very much, but unfortunately it is not working. Games do not start with this new retroarch binary. I tried local game without netplay, locally started netplay and join to existing netplay session, none of them worked. I will wait until the next official stable version.



Want to support us ?

Join us on :

599
Online

31253
Users

15144
Topics

113899
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.