PS3 Controller - can't get it to work :(



  • I've tried 3 different bluetooth dongles and I'm getting similar result with all of them. reset PS3 controller with a pin, Install recalbox, boot it, with bluetooth dongle in the pi2, plug in the ps3 controller via USB, wait for 10 seconds then disconnect, press the PS button to connect. At that point it vibrates as though it had connected, but when I go to configure it it's not showing in the p1 controller nor recognised when I hold a button to configure it :( Am I doing something wrong? If not, can some one point me in the right direction for a (hopefully cheap) BT dongle that does work? is there a way to test via the command line? Thanks in advance



  • Check this: https://github.com/digitalLumberjack/recalbox-os/issues/30 I had the same issue and was the bluetooth dongle.



  • Yeah, unfortunately I thought that was probably the case, which one did you have that worked? on checking it looks like all mine are CSR devices despite being different brands and are listed as not working :(


  • Team

    You can try an other power suplly, a better one before buying a new bluetooth dongle. It worked for some people :)



  • Bad Bluetooth adapter: switching to a decent branded one has solved the problem :) LOVING the work you're doing, it's awesome, as soon as I can I'll donate. One minor issue: has anyone got Super Mario World to work? I know the controllers are switched, but I can't get it to work


  • Team

    Hi James, Super Mario World works really well if you overclocked your rpi. Get a good rom. The controllers are inversed on Super Mario All Stars only.



  • Sorry, I should have been clearer, the rom works perfectly, but I can't get the controller to work, even if I set p1 and p2 to use the same controller, I can't use the (now working (YAY!!)) ps3 controller to control the game, Zelda (for example) however works perfectly. Thanks for all the help so far :)


Log in to reply
 

Want to support us ?

Join us on :

401
Online

31158
Users

15126
Topics

113815
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.