[MULTIJOUEUR][SNES] Problème pour certains jeux SNES



  • Bonjour, Je souhaitais déjà remercier le créateur de recalbox. C'est propre, c'est beau et ça claque! Voici ma configuration : - Raspberry <del>PI2 </del>PI1 (Raspberry PI Modell B Rev 2.0, 512MB) - Recalbox v3.2.11 - 2 manettes iBuffalo classic USB Gamepad(celle ressemblant à celle de la SNES) Comme certaines personnes, j'ai des problèmes avec le multijoueur. Pas de soucis pour mariokart par exemple mais problème pour : - Bomberman : comme Bibine0505, il faut appuyez sur une touche de la manette1 pour que la menette2 puisse fonctionner - Double dragon : la manette 1 commande les 2 players J'ai bien lu la solution de Gael : http://blog.recalbox.com/forums/topic/multijoueur-sur-snes-solution/ mais elle ne fonctionne pas chez moi. J'ai essayé de changer l'emulateur en passant sur snes_emulator=snes9x mais le problème demeure. Ce qui est étrange, c'est de voir que pour mario kart, cela fonctionne nickel donc je ne vois pas pourquoi cela viendrait de l'emulateur... Merci à vous pour vos idées, votre analyse et bon gaming à tous!


  • Staff
    Developer
    Global moderator
    Team

    Salut, pourtant c'est bien un problème de l’émulateur. Si ça marche sous mario kart, c'est que la configuration automatique des manettes fonctionne. Tu peux essayer avec snes9x_next, ou catsfc pour voir si ils corrigent le tir.



  • Merci pour ta réponse. Je ne savais pas que snes9x_next était présent dans la version 3.2.11. J'ai donc modifier le fichier recalbox.conf de la sorte : # ------------ I - EMULATORS CHOICES ----------- # ## If two emulators are available for a platform you can switch here ## SNES : use pocketsnes (recommended for rpi1), catsfc or snes9x #;snes_emulator=pocketsnes snes_emulator=snes9x_next Pas de changement pour les jeux cités plus haut. Comment s'assurer que l'émulateur snes a bien changé? Est-il normal de retomber sur pocketnes lorsque l'on appuie sur la Hotkey+B?



  • Comme écrit dans le recalbox.conf ## SNES : use pocketsnes (recommended for rpi1), catsfc or snes9x, pour switcher d'émulateur, tu dois saisir : snes_emulator=snes9x et non pas snes_emulator=snes9x_next to utilisera alors bien snes9x_next. Il faut également utiliser un éditeur de texteur potable comme notepad++ si tu es sous windows (wordpad, blocnote etc... à proscrire) Dernière recommandation, passer sous la bêta 3.3.0, car la 3.2.11 est obsolète maintenant, il ne sera pas possible d'upgrader de la 3.2.11 vers la 3.3.0, et vu que l'on arrive sur la fin de la phase bêta, la 3.3.0 n'a de bêta que le nom. Elle est hyper stable.



  • Ok, je viens d'installer la version 3.3.0 (dernière beta). Je configure les manettes, je repose les roms et je te fais un retour.



  • Ok, Bomberman et Double dragon fonctionnent!!! Super! Merci bien! Il suffisait jsute d'installer la version 3.3.0. Merci beaucoup!



  • Après quelques tests sur SNES (avec l'émulateur par défaut donc pocketsnes), il s'avère que le son est moins bon et qu'il y a des petits moments de ralentissement (on le sent en jouant à Mario Kart) par rapport à la v3.2.11. Préconises-tu de passer sur snes9x_next? Merci!



  • Oh que oui passe sur snes9x_next ! Tu as un Pi2, profite de sa puissance. L'émulation sera largement meilleure avec snes9x_next 😉



  • Bon malheureusement, je viens de voir que contrairement à ce que je pensais, je suis sur un Raspberry PI Modell B Rev 2.0, 512MB (donc le 1) 😞 Du coup, j'imagine qu'il est préférable de rester sur pocketsnes?


Log in to reply
 

Want to support us ?

245
Online

81.3k
Users

22.2k
Topics

161.2k
Posts