Recalbox 7.0

Xbox 360 Wireless Controller Support



  • Firstly, I'd like to start by saying a BIG THANK YOU to 'digitalLumberjack' for the absolute ULTIMATE retro gaming experience for the Raspberry Pi 2! Recalbox is the nicest looking, simplest, cleanest and most efficient emulator package / frontend / media centre that I've ever used! Now, I've just downloaded the updated recalboxOS v3.3.0-beta-9 tonight and tried out my Xbox 360 Wireless Controller for the first time (using a USB Adapter I purchase off eBay a few years ago) and everything works perfect... and it discovers BOTH of my controllers within seconds... Absolutely Brilliant! ...However, when I'm configuring the controller, it will not correctly recognise my INPUT for both LT and RT TRIGGER's... It shows on screen that words "hold any button for 1 second to skip" and then it skips RT trigger as soon as I press LT and says "not configured" for the button and it looks like I'm left with a partially mapped controller... Please help! *PS: I've just tried Mario Kart 64 (the best game with friends ever!) and it seems that it DID in fact map both the LT and RT... and LB and RB buttons 🙂 Thank you once again digitalLumberjack! You're a Legend 😄


  • Developer
    Global moderator
    Team

    Hi ! See https://github.com/digitalLumberjack/recalbox-os/wiki/Manual-(EN)#xboxcontrollers and follow the link for xboxdrv. Just edit recalbox.conf with notpad ++ and change the line to enable the driver. All will be ok. Just for info, you did not had to remap the controller. It was already working out of the box...



  • Thank you very much for the quick response 🙂


  • Developer
    Global moderator
    Team

    Hi, just for information and for people hanging there, @Sikahalv i see that you have a Samsung EVO 32GB. Be sure to always clean shutdown the RPi as it is known to be a problematic sd card, that can screw your file system on hard reboots. The recommended SD card are SANDISK ULTRA SERIES



  • Thanks @digitalLumberjack I've now purchased 32GB Sandisk Ultra 80mbps Micro SD card 🙂



  • Hey, first of call a big thank you for the recalbox 🙂 wonderful project!!   I have a problem with the xbox 360 controller and the psx emulator. The button do work, but they are switched. E.g. "x" at the psx is the "a" button on the controller. The other gaming consoles are working great. The buttons were mapped in the menu. I already changed the "controllers.xboxdrv.enabled=1" line and disabled the line for ps3. The right biosfile is placed in the right folder.   Is is possible to change it?



  • I double checked everything and did a fresh install.. no progress 😞 The strange part is, it all worked perfectly a few weeks ago.





  • I tried to enable the xbox controller in the recalbox.conf, but just received the following errors in the kodi.log: CLinuxInputDevice::KeyEvent: TranslateKey returned XBMCK_UNKNOWN from code(310) I ended blacklisting xpad /etc/modprobe.d/blacklist file contents: blacklist xpad and create a new startup script /etc/init.d/S99xboxdrv placed this in the S99xboxdrv file: xboxdrv --trigger-as-button --wid 0 --led 2 --deadzone 4000 --silent & sleep 1 xboxdrv --trigger-as-button --wid 1 --led 3 --deadzone 4000 --silent & sleep 1 xboxdrv --trigger-as-button --wid 2 --led 4 --deadzone 4000 --silent & sleep 1 xboxdrv --trigger-as-button --wid 3 --led 5 --deadzone 4000 --silent &


Log in to reply
 

Want to support us ?

187
Online

79.1k
Users

20.3k
Topics

149.0k
Posts