Moonlight not working



  • Good evening,
    after the latest update Moonlight didn't work for me anymore. So I tried to pair my pc and my recalbox again and it sais:
    ...
    Searching for server...
    Connect to 192.168.0.5...
    Generating certificate...done
    Can't connect to server 192.168.0.5
    ERROR mlPair() : could not pair. Exiting ...

    Using the "clean" command and reseting all entries in GFE / Shield didn't work neither.

    Any ideas?

    Above IP Adress is correct (=from my PC)
    Iam using the latest Geforce Driver. 391.35



  • Problem solved. GFE installed version 3.13 which isnt supported yet. Downgraded and working fine now again.

    Thank you!



  • @fuzzel have you tried the "find" otion first ? Looks like either gfe hasn't started on your pc, either network problems



  • Yes, i found the problem: It was not on account of Recalbox, but GFE. It always updates to Version 3.13. The solutions I have found on the internet (Deletions of Update files, Update Blocking in firewall etc.) don't work. It always updates from 3.12 to 3.13.

    Is there a solution for this "update problem"? Sorry, its no Recalbox problem, just connected to it.
    May I ask this in this forum?



  • @fuzzel are you saying it doesn't work with gfe 3.13 ?



  • I think so. With GFE 3.12 it works, with GFE 3.13 it does not.

    This also conforms with the changelog of Recalbox 18.03.16: "Moonlight: bump to 2.4.6, supports up to GFE 3.12 [...]"
    https://www.recalbox.com/blog/en/post/blog-2018-03-16-recalbox-18.03.16/



  • @fuzzel be cause i had not tested with GFE 3.13, and i saw no mention of changes in the gamestream protocol in GFE 3.13



  • Maybe other users have ohter experiences? My recalbox/moonlight doesn't run with GFE 3.13 but with GFE 3.12.



  • @substring I confirm, with GFE 3.13.1.30 it work, I can view my desktop, play games and videos from the web or VLC.

    I used the commands :

    cd /recalbox/scripts/moonlight
    ./Moonlight.sh pair <MY_IP>
    ./Moonlight.sh init <MY_IP>
    reboot

    Sometimes, the application or games won't launch but I can view my desktop and I can launch the application or the game, it's not a problem for me. The sound work fine.

    I need only to stop the stream with GFE from Shield - GameStream option to get back in the menu of the Recalbox.


Log in to reply
 

Want to support us ?

Join us on :

168
Online

29728
Users

14871
Topics

112047
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.