N64, son pas assez fort et ajuster écran



  • Bonjour,

    Je rencontre 2 petits problèmes avec l'émulateur N64.

    J'ai lancé 2/3 jeux, aucun problème, mais le son n'est pas assez fort (à peine audible) et j'ai des bandes noires en haut/bas/droite de l'écran.

    J'ai cherché sur le forum sans succès, je me permets donc de poser deux questions : Est-il possible de :

    • Augmenter le volume de l'émulateur ?
    • Ajuster l'affichage à mon écran ?

    Merci d'avance pour votre aide.



  • @retlaw yo
    si tu ne dis ni quelle board tu utilises, ni quel moniteur, que veux-tu que je te réponde ?



  • Salut @Substring !

    Ah... La signature en bas de mes messages n'apparait que chez moi ??? (va falloir que je regarde pourquoi...)

    Ecran cathodique 4/3, Rpi3.
    (Je profite de l'occasion que dans recalbox.conf, j'ai bien mis n64.videomode=default)



  • @retlaw persone ne lis la mienne qui demande de me notigier en me répondant donc bon ;)

    tu peux faire une capture d'écran en utilisant le webmanager stp et la poster ici ? je voudrais vérifier un truc.



  • @substring said

    persone ne lis la mienne qui demande de me notigier en me répondant donc bon ;)

    Ah, tu me rassure, je pensais que mon profil buguait ;)

    Tu veux une capture d'écran de recalbox.conf ?

    text alternatif



  • @retlaw non non non, une capture quand tu joues à la N64. L'idée est de voir si la capture reflete ton pb à l'écran ou pas



  • @substring

    Capture d'écran via l'interface :
    text alternatif

    Et une petite photo faite à l'arrache pour illustrer mon problème :
    text alternatif

    On voit que l'image est bien collée à la bordure gauche, mais en rempli pas tout l'écran... (petite bande en bas, grosses en haut et à droite)



  • Hello !

    Personne n'a une idée qui pourrait résoudre mon problème ?



  • Je ne sais pas.trop quoi en penser, si ce n'est qu'il n'y a pas de problème de reglage sur ton écran et que l'emulation se fait bien avec cette résolution. Ca m'etonne quand même bcp


  • CRT Fan

    Salut !
    tu utilises quoi comme connectiques pour ton crt? hdmi ou gpio ?
    tu boot avec quelle résolution dans le config.txt ?
    tes autres jeux sont bien cadrés, peut importe la console ?

    PS : as tu configuré un fichier viewport pour la n64, si oui, contenu ?



  • @substring said in N64, son pas assez fort et ajuster écran:

    Ca m'etonne quand même bcp

    Moi aussi !

    @idarius said in N64, son pas assez fort et ajuster écran:

    tu utilises quoi comme connectiques pour ton crt?

    Salut !

    J'utilise jack => RCA (j'ai bien une Pi2scart, mais je n'arrive pas à la faire fonctionner...Image saccadée +++ et déformée +++ )

    @idarius said in N64, son pas assez fort et ajuster écran:

    tu boot avec quelle résolution dans le config.txt ?

    J'ai mis sdtv_mode=2
    (et disable_overscan=0 pour que le menu de recalbox ne soit pas rogné)

    @idarius said in N64, son pas assez fort et ajuster écran:

    tes autres jeux sont bien cadrés, peut importe la console ?
    Oui... Je n'ai utilisé qu'une fois (pour la snes je crois) le menu de retroarch pour recadrer l'image de 0,5/1 cm.
    Pour les autres émulateurs, je n'ai rien eu à faire.

    Sauf qu'avec l'émulateur de la N64, il n'y a aucun menu permettant de recadrer quoi que ce soit...

    @idarius said in N64, son pas assez fort et ajuster écran:

    PS : as tu configuré un fichier viewport pour la n64, si oui, contenu ?

    Non, je n'ai rien fait de ce coté là, je n'ai trouvé nul part d'information sur ce fichier. Je ne savais même pas qu'on pouvait/devait le modifier.
    Si je dois intervenir dedans, où se situe ledit fichier et que dois-je modifier ?



  • N64, ce n'est pas un core retroarch. Mais tu peux regarder si'il y en a un de duspo sur pi, m'en souviens plus.


  • CRT Fan

    il y a bien un core retroarch pour la N64.
    Via le menu recalbox (start) tu va dans parametres avancés => configuration avancée de l'émulateur => nintendo 64
    Puis tu choisi Libretro en emulateur, et glupen64 en core.

    Ensuite via le menu retroarch (hotkey + B en jeu) tu va dans settings => video, et ici tu peux jouer avec custom aspect ratio width et height pour la taille de l'image, et custom aspect ratio X et Y pour la position de l'image.

    Par contre je n'ai jamais testé de me connecter en S video donc je vais pas pouvoir t'aider si c'est un probleme de config de ce coté la.

    Mais tu devrais pouvoir redimensionner ton image, et la cadrer via le menu retroarch.

    Pour sauvegarder les changements, tu va dans le dossier partagé recalbox via le reseau, puis dossier system => configs => retroarch.
    tu crée un fichier n64.cfg qui doit ressembler à ça, avec tes valeurs :

    aspect_ratio_index = "22"
    video_smooth = "false"
    video_scale_integer = "false"
    video_threaded = "false"
    custom_viewport_width = "678"
    custom_viewport_height = "480"
    custom_viewport_x = "31"
    custom_viewport_y = "0"

    tu sauvegarde, en ayant pris soin de quitter l'emulateur avant.
    Quand tu relancera, ça gardera tes valeurs.



  • @idarius said in N64, son pas assez fort et ajuster écran:

    Puis tu choisi Libretro en emulateur, et glupen64 en core.

    J'avais essayé avec ce core sans arriver à quoi que ce soit, mais j'avais configuré le core uniquement pour le jeu Banjo-Kazooie sur lequel je faisais les tests (via le menu "éditer les données du jeu"), mais visiblement, forcer un core spécifique via l'édition d'un jeu ne fonctionne tout simplement pas ! )

    En revanche, en sélectionnant le core pour l'ensemble de l'émulateur en passant via le menu général de Recalbox, ça fonctionne.

    Donc en sélectionnant simplement le core glupen64 dans le menu général, tout est rentré dans l'ordre (je n'ai pas eu besoin d'aller dans le menu retroarch pour régler mon problème de vidéo.)

    Mais du coup, maintenant que j'ai accès au menu rétroarch, j'ai pu régler mon problème de son !

    Merci pour l'astuce @idarius !!

    Edit : Je ne vois pas comment éditer le titre du topic pour le passer en résolu. Si @Substring passe par là, peux-tu le faire STP ?



  • @retlaw tu vas dans outils d'un sujet, tu le passes en question tunretournes dans le menu et tu le marques en résolu



  • @Substring , Merci pour l'info ! Je m'endormirai moins bête ce soir !

    [boulet]J'avais bien vu cette option, mais je pensais que c'était pour poser une question à l'auteur du topic...
    Je n'avais donc pas cliqué dessus[/boulet] lol


  • CRT Fan

    Content d'avoir pu t'aider :)
    Bonne fin de weekend a toi !


Log in to reply
 

Want to support us ?

Join us on :

623
Online

28900
Users

14666
Topics

110821
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.