Not booting after update



  • I updated to 4.0.2. Now when I turn my Pi Zero W, TV detects a signal, but it is only black.

    Are there any recovery options or do I need to restore from image?



  • I have the same issue with a clean install on a raspberry pi 2. I have a hifiberry, a wifi dongle, a bluetooth dongle, a usb mouse and a usb keyboard attached.
    I've tried to boot it with and without all that stuff attached. The green light flashes, and flashes shortly again. Then it won't flash again.
    I created the sd card with windows via etcher, with linux using dd, and also tried to alter the boot partition (boot flag, primary). Screen stays black.



  • I tried connecting a usb keyboard and holding shift while booting, no difference.

    I also tried mounting the share partition with Diskinternals Linux Reader and it says my share partiton is empty.


  • Moderator
    Team

    @flibb how have you installed Recalbox ? You can't upgrade to 4.0.2 as the upgrade is not anymore available since october



  • @substring Sorry, I got the number wrong. I upgraded to 18.02.09 from the previous version to that which I installed from image with Etcher.


  • Moderator
    Team

    @flibb can you ssh yo your pi ? Can you make a support archive ? What does tvservice -s report ?



  • I tried a fresh install of 18.02.09 and it appears to not boot (red and green led's on the pi light up and stay illuminated). I found a "config.txt" file in the imaged SD card's main directory. I uncommented the following line:

    #uncomment if you get no picture on HDMI for a default "safe" mode
    #hdmi_safe=1

    Then recalbox appeared to boot, but the output to the monitor was glitchy (lots of screen artifacts and the image is not filling nor centered on the display) and flashed on and off every few seconds. So it appears that recalbox may be booting but similar to what @flibb said, it is outputing an incompatible signal to the display. My monitor says "input not supported" but @flibb 's TV must just display a black screen for unsupported inputs.

    Raspberry Pi 3 Model B
    32GB Samsung EVO Class 10 microSD card
    1080p HDMI Acer display
    Keyboard and Xbox 360 controller connected before powering on Pi


  • Moderator
    Team

    @albannach1 can you try the old way : install noobs on the sd, and then net install recalbox ?



  • @Substring I tried installing NOOBS, adding recalboxOS-rpi3 to the os folder of NOOBS. Install went ok. As soon as I boot into recalbox, I still get the "input not supported" error on the display. I confirmed that Raspbian outputs to display and works normally on this same hardware. Maybe there is a display driver issue in the new version of recalbox?

    I used the instructions here: https://github.com/recalbox/recalbox-os/wiki/Setup-a-dual-boot-raspbian-recalboxOS-(EN)
    And used the 4.1.0 recalboxOS zip found here: https://github.com/recalbox/recalbox-os/releases


  • Moderator
    Team

    @albannach1 I said "net install", you just had to scroll down in the list of OS proposed by NOOBS and you'll ee Recalbox ...

    so, most probably a pi firmware issue then



  • @substring said in Not booting after update:

    st probably a pi firmwa

    @Substring I am currently operating out of a hotel at the Olympics so my troubleshooting and networking options are limited. I do not know my ip address and probably cannot access it from another device. I enabled safe mode in the config and this made no change. I commented the splash line and I do get the rainbow splash screen, then it is black. My monitor is reporting a signal at 640x480@60Hz.

    I have another sd card with raspbian, I will see if there is a firmware update.



  • @substring I updated firmware to 4.14 and same issue. If I disable safe mode, I get a 720p60 signal, but black. It seems stuck in a reboot loop, the green led stays on for about 1-2 minutes with a black 720p signal, then flashes off and on and the monitor re-detects the signal.


  • Moderator
    Team

    @flibb 4.14 ? Nah, just get raspbians boot files but the kernel. Sonfar you're the 2nd one not being able to have a working screen


  • Banned

    This post is deleted!

Log in to reply
 

Want to support us ?

Join us on :

1016
Online

25487
Users

13351
Topics

101181
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.