Recalbox 7.0

Analog joysticks in MAME



  • I'm running the following setup:
    Ultimarc UltraStik 360 joystick, 6 buttons in SF2 style config wired to it + Start/Select

    I cannot get the analog to work. I know that the joystick is in Analog mode because I spent extensive time ensuring that RGBcommander is running (even working with the developer to support Recalbox specifically) and I know it's switching joystick profiles, and the /dev/js* files are outputting full analog resolution.

    The joysticks work but they act like 8-way/D-Pad....digital, not analog. Games like Afterburner don't have any resolution to the input, as soon as you hit any directional input it's at max.

    I've tried a lot to get it to working....and I'm just at a total loss. I'm using MAME 2003 aka 078 and I've tried other cores (MAME 2010, IMAME4ALL) ..

    I am just using a single analog USB joystick, not a gamepad, so I'm not sure if the analog works when you have both the D-Pad and Analog joystick inputs configured in the controller config.. but you can only setup the D-Pad controls in the controller config when you are using a single directional input.

    Thoughts?



  • as it says in the config wizard "If you have only one joystick, configure the directions keys and skip joystick config" -- sure but does this mean that I also forego analog support?

    I have only one joystick...and it's analog...does configuring it as D-Pad make me lose analog support? The joystick is outputting analog... but what in the whole recalbox/emlulationstation/retroarch/libmame chain is preventing those analog signals from being interpreted as analog and ending up as digital?



  • @metahacker you're a particular case ... Analog on the dpad ... Anyway, it'should be a problem as they shouldnbe recorded as analog sticks, not digital pad (ansupport arcjive would help me.to confirm)

    Next things : make sure your pad is set as analog in retroarch, i don't think it's the case by default



  • This post is deleted!


  • @substring how? you can't skip d-pad in the controller config wizard... edit config file directly?



  • Hmm It seems I can set up joystick as analog "Joystick 1" if I cheat the Controller Config Wizard using a second controller or keyboard input to skip the D-Pad section...... but then with no D-Pad, the front end menus don't work anymore......



  • @metahacker be it "resitered" as dpad doesn't mean we store a digital input 😉 The es_input.cfg file that knows about all controllers stores much more information : is it a button, a hat, or an axis 🙂 And it will be recorded as an axis, hence analogue. So I still think you should dive in the RA configuration



  • @substring ive tried many many things and still cannot get it to work. i am 100% sure that the joystick is outputting analog to mame (as verified by jstest while game is running) ...

    i notice that recalbox keeps writing retroarch config with input_libretro_device_p1 = 1 not 5... will that cause it to not work?



  • hmm even with custom cfg file setting value to 5 no change....
    the analog is digital i just dont get it. ive tweaked everything i can think of and more, dead zones etc.. i just dont get it. arch rivals, sinister, after burner, none of these games will play as analog...



Want to support us ?

187
Online

79.1k
Users

20.3k
Topics

149.0k
Posts